Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[REQUEST] New PIPO P9 4G
Avatar
Otura
Active Member
Forum Posts: 38
Member Since:
2016/12/02
sp_UserOfflineSmall Offline
1
2016/12/02 - 17:51
sp_Permalink sp_Print

Hello.

I've just bought the new version of the PIPO P9 with 4G support.

The rom CrewRKTablets_RK32_Pipo_P9_CM13_6.0.1_v1.5.3 by Oma7144 works perfectly till now, but the SIM is not detected.

Oma, I don't know if you have the time to investigate a fix for that.

If you need someone with the hardware for testing or whatever, I volunteer. If I can be of help any other way, just let me know.

 

Thanks for the good work with the RK3288!!

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1373
2
2016/12/03 - 17:02
sp_Permalink sp_Print

Yeah, new tab in town 😉

Here is kernel #317 preempt 11 Nov 2016: http://crewrktablets.arctablet.com/?wpfb_dl=2972

Flash kernel and resource and report back.

- Oma -

flash_kernel.pngImage Enlargerv1.5.3_18.pngImage Enlarger

sp_PlupAttachments Attachments
Avatar
Djuganight
Portugal
Regular Member
Forum Posts: 97
Member Since:
2013/04/28
sp_UserOfflineSmall Offline

Thanks Received: 2
3
2016/12/03 - 18:23
sp_Permalink sp_Print

does this work on Pipo P9 wi-fi?

Pipo P9

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1373
4
2016/12/03 - 18:33
sp_Permalink sp_Print

I would not recommend to use this build on older hardware revisions.

- Oma -


Avatar
Otura
Active Member
Forum Posts: 38
Member Since:
2016/12/02
sp_UserOfflineSmall Offline
5
2016/12/04 - 20:50
sp_Permalink sp_Print

Hello Oma!

 

Thanks for the super-fast answer!

 

I've just done a dirty flash of CM13 again, but replacing kernel, resources and recovery (TWRP 3.0.0).

 

Then in TWRP I've applied the lens fix, the audio fix and the root.

 

Dalvik and cache wipes.

 

Reboot.

It did not work. BTW, bluetooth was not working neither.

 

I'm going to do a clean flash and will let you know.

Avatar
Otura
Active Member
Forum Posts: 38
Member Since:
2016/12/02
sp_UserOfflineSmall Offline
6
2016/12/05 - 08:36
sp_Permalink sp_Print sp_EditHistory

Hi again.

2nd round.

I've done this:

 

1. Extracted CrewRKTablets_RK32_Pipo_P9_CM13_6.0.1_v1.5.3.

2. Replaced kernel.img and resource.img with those from kernel #317 preempt 11 Nov 2016 (link above).

3. Rebooted tablet on Bootloader.

4. Lower format.

5. Flash (Run) CM13 1.5.3 + kernel/resource #317 + TWRP 3.0.0

6. On TWRP flash (you can find all those here http://crewrktablets.arctablet.com/?page_id=208): 

  • Oma_RK32_P9_lens_fix.zip
  • CrewRKTablets_RK32_CM13_improve_UI_performance.zip
  • mussonero_RK32_Pipo_P9_CM13_6.0.1_v1.5.3_audio_fix.zip
  • Oma_RK32_Root.zip

7. Wipe Dalvik Cache and reboot system.

8. PiPO logo... 4 round colorful thingies doing their spinning and things... wait... wait longer... waaaaait loonger...

9. System boots up, but no SIM detected. Bluetooth is working now.

 

I will give it a third run with a full data wipe and factory reset.

Avatar
Otura
Active Member
Forum Posts: 38
Member Since:
2016/12/02
sp_UserOfflineSmall Offline
7
2016/12/05 - 13:56
sp_Permalink sp_Print

Hi!

Third run:

1. Reboot to recovery:

  • Format data
  • Factory reset
  • Advanced wipe: Dalvik/ART cache, cache, data and internal storage

2. Reboot to bootloader

  • Lower format
  • Flash "CrewRKTablets_RK32_Pipo_P9_CM13_6.0.1_v1.5.3" as-is.
  • It reboots to TWRP.

3. Reboot again to bootloader:

  • Flash resource.img and kernel.img from "RK32_sekernel_310_p9_4g_317_pipo.7z".
  • It reboots to system.

4. It gets stuck in "Preparing to start/Starting apps..."

5. Reboot to TWRP

  • Apply "Oma_RK32_P9_lens_fix.zip"
  • Wipe Dalvik cache
  • Reboot to system

Result:

a. System boots.

b. Android and CM setup wizards trigger.

c. Bluetooth works.

d. SIM is not detected.

 

I've tried with a couple of SIMs and none of them work in the P9 4G, but they do in other devices.

 

Oma, do you have any advice? I'm stuck here.

If you need anything from me let me know (config files, logs, device info...)

Avatar
Otura
Active Member
Forum Posts: 38
Member Since:
2016/12/02
sp_UserOfflineSmall Offline
8
2016/12/05 - 17:29
sp_Permalink sp_Print

I've just realized that my baseband version reads "Unknown", while in your screenshot is V3.4.00401.

 

Maybe I've done something wrong? (most probably yes)

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1373
9
2016/12/05 - 19:57
sp_Permalink sp_Print

Is the SIM card plugged while booting?

- Oma -

Avatar
Otura
Active Member
Forum Posts: 38
Member Since:
2016/12/02
sp_UserOfflineSmall Offline
10
2016/12/05 - 20:22
sp_Permalink sp_Print

Yes,  it's in the slot. I've just rebooted to confirm that.

Previously I flashed some of the other releases (MM and CM13 1.4.X) and at a moment in time I flashed the 3G OFF and ON patches.  I don't know if that could had messed the IMEI (just shooting blind here).

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1373
11
2016/12/05 - 20:30
sp_Permalink sp_Print

Pls let me have a dmesg and a logcat log from a fresh boot.

- Oma -

Avatar
Otura
Active Member
Forum Posts: 38
Member Since:
2016/12/02
sp_UserOfflineSmall Offline
12
2016/12/05 - 22:18
sp_Permalink sp_Print sp_EditHistory

There you go.

Avatar
Otura
Active Member
Forum Posts: 38
Member Since:
2016/12/02
sp_UserOfflineSmall Offline
13
2016/12/06 - 08:04
sp_Permalink sp_Print

And there.

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1373
14
2016/12/06 - 20:17
sp_Permalink sp_Print

Pls install this via TWRP: http://crewrktablets.arctablet.com/?wpfb_dl=2973

- Oma -

Avatar
Otura
Active Member
Forum Posts: 38
Member Since:
2016/12/02
sp_UserOfflineSmall Offline
15
2016/12/06 - 23:10
sp_Permalink sp_Print

Done.

 

Same outcome.

 

Logs attached.

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online:
103 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (89), Phone (13), Tablet (1)

Top Posters:

Oma7144: 6315

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 432

maikal: 394

Newest Members:

mariorossiprovaa

vodesik

wanzan

p7f

archos97carb

TR3WAR

Forum Stats:

Groups: 10

Forums: 185

Topics: 6003

Posts: 60373

 

Member Stats:

Guest Posters: 43

Members: 260281

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix