Forum switched to read-only as of 2020/06/01


Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[ RK3288 ROM ] IFive Mini 4 LineAgeOS 14.1 custom root firmware (2017/06/09)
Avatar
MiGHT.
Germany
Regular Member
Forum Posts: 67
Member Since:
2014/09/11
sp_UserOfflineSmall Offline

Thanks Received: 13
16
2017/06/24 - 20:03
sp_Permalink sp_Print sp_EditHistory

Alright,

last_kmsg kernel #8 - some debugsymbols are missing
https://pastebin.com/dAuksz9r

 

dmesg #7
https://pastebin.com/AsSWDAnq

See this, too:

[    1.575762] init: finit_module for "/system/lib/modules/mali_kbase.ko" failed: Exec format errorinit: insmod: open("/system/lib/modules/rk30_mirroring.ko") failed: No such file or directoryinit: insmod: open("/system/lib/modules/rk29-ipp.ko") failed: No such file or directoryinit: insmod: open("/system/lib/modules/wlan.ko") failed: No such file or directoryinit: write_file: Unable to open '/sys/kernel/debug/tracing/tracing_on': No such file or directory

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1386
17
2017/06/24 - 20:52
sp_Permalink sp_Print

This is what KK log tells us:

<6>[ 1.186304] i2c i2c-1: sensor_probe: gs_mma8452,0xdd6eac00
<7>[ 1.186318] of_get_named_gpio_flags exited with status 256
<7>[ 1.186324] of_get_named_gpio_flags: can't parse gpios property
<7>[ 1.186328] of_get_named_gpio_flags: can't parse gpios property
<7>[ 1.186333] of_get_named_gpio_flags: can't parse gpios property
<4>[ 1.186343] sensor_chip_init:gs_mma8452:devid=0x0,ops=0xc0d1f538
<6>[ 1.188072] input: gsensor as /devices/ff140000.i2c/i2c-1/1-001d/input/input2
<4>[ 1.188336] sensor_misc_device_register:miscdevice: mma8452_daemon
<4>[ 1.188345] sensor_probe:initialized ok,sensor name:mma8452,type:2,id=17
<4>[ 1.188345]
<6>[ 1.188391] i2c i2c-1: sensor_probe: ak8963,0xdd6eae00
<7>[ 1.188402] of_get_named_gpio_flags exited with status 257
<7>[ 1.188407] of_get_named_gpio_flags: can't parse gpios property
<7>[ 1.188412] of_get_named_gpio_flags: can't parse gpios property
<7>[ 1.188416] of_get_named_gpio_flags: can't parse gpios property
<4>[ 1.188423] sensor_chip_init:ops is null,sensor name is ak8963
<3>[ 1.188431] i2c i2c-1: sensor_probe failed -1
<3>[ 1.188431]
<4>[ 1.188444] sensors: probe of 1-000d failed with error -1
<6>[ 1.188471] i2c i2c-1: sensor_probe: ewtsa_gyro,0xdd6eb000
<7>[ 1.188480] of_get_named_gpio_flags exited with status 258
<7>[ 1.188485] of_get_named_gpio_flags: can't parse gpios property
<7>[ 1.188490] of_get_named_gpio_flags: can't parse gpios property
<7>[ 1.188495] of_get_named_gpio_flags exited with status 265
<4>[ 1.188504] sensor_chip_init:ewtsa_gyro:devid=0x0,ops=0xc0d1f594
<6>[ 1.246096] input: gyro as /devices/ff140000.i2c/i2c-1/1-0069/input/input3

- Oma -

Avatar
MiGHT.
Germany
Regular Member
Forum Posts: 67
Member Since:
2014/09/11
sp_UserOfflineSmall Offline

Thanks Received: 13
18
2017/06/24 - 21:15
sp_Permalink sp_Print

Yes, there is the ak8963 sensor - this is a hallsensor, did you include hallsensor compatibilty in kernel config?

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1386

Avatar
MiGHT.
Germany
Regular Member
Forum Posts: 67
Member Since:
2014/09/11
sp_UserOfflineSmall Offline

Thanks Received: 13
20
2017/06/24 - 22:45
sp_Permalink sp_Print

Kernel boots, no reaction to magnetic sensor

dmesg #9

https://pastebin.com/ZJwyGpQ1

 

[    2.115124] init: Service akmd does not have a SELinux domain defined.

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1386
21
2017/06/25 - 08:02
sp_Permalink sp_Print

Is the compass working? Play around with detecting apps.

Is the sensor located where the flipcover magnet is? Use this app for detecting the magnetic field: https://play.google.com/store/apps/details?id=at.lab.sensorcollection

- Oma -

Avatar
MiGHT.
Germany
Regular Member
Forum Posts: 67
Member Since:
2014/09/11
sp_UserOfflineSmall Offline

Thanks Received: 13
22
2017/06/25 - 13:04
sp_Permalink sp_Print sp_EditHistory

Compass is not working and any SensorTools doesnt recognize any valuechanges from sensor.

Maybe the problem is android-related?

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1386
Avatar
MiGHT.
Germany
Regular Member
Forum Posts: 67
Member Since:
2014/09/11
sp_UserOfflineSmall Offline

Thanks Received: 13
24
2017/06/25 - 19:38
sp_Permalink sp_Print

I would.... 😉

File Oma_RK32_P4_LineageOS 14.1_v1.2.4_modell_fix_mini4.zip not found!

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1386
Avatar
MiGHT.
Germany
Regular Member
Forum Posts: 67
Member Since:
2014/09/11
sp_UserOfflineSmall Offline

Thanks Received: 13
26
2017/06/25 - 19:55
sp_Permalink sp_Print

Still no sensor and no compass recognizing.

dmesg after Model Fix:
https://pastebin.com/tt1mQkaf

[    2.109183] init: Service akmd does not have a SELinux domain defined.

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1386
Avatar
MiGHT.
Germany
Regular Member
Forum Posts: 67
Member Since:
2014/09/11
sp_UserOfflineSmall Offline

Thanks Received: 13
28
2017/06/25 - 21:25
sp_Permalink sp_Print

Alright, we got further.

Compass is working now, magentic sensor does change value.
But no action defined in android, so technically its working, but android dont know what to do with it.

 

Model Fix #2 dmesg
https://pastebin.com/qE6XJXad

Service is starting successfully:

[ 2.050491] type=1400 audit(1498418600.480:6): avc: denied { entrypoint } for pid=196 comm="init" path="/system/bin/akmd" dev="mmcblk0p10" ino=933 scontext=u:r:akmd:s0 tcontext=u:object_r:system_file:s0 tclass=file permissive=1

 

Thanks again for your effort.

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1386
29
2017/06/25 - 22:03
sp_Permalink sp_Print

Pls install Androsensor (see Play Store). Open the graph for Magnetic field. Do a screenshot while holding the flip cover magnet on its place.

- Oma -

Avatar
MiGHT.
Germany
Regular Member
Forum Posts: 67
Member Since:
2014/09/11
sp_UserOfflineSmall Offline

Thanks Received: 13
30
2017/06/26 - 07:47
sp_Permalink sp_Print

I did that, see sir:
No reaction to that cover...if i move the tablet or hold an speaker on it, the graph peaks out.

screen.pngImage Enlarger

Forum Timezone: Europe/Paris

Most Users Ever Online: 803

Currently Online:
209 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (190), Phone (19)

Top Posters:

finless: 604

DarthJabba: 551

maikal: 394

mussonero1: 350

alex: 252

damo: 243

DanielVd: 237

Mark06: 222

Newest Members:

ppaofe

kabelodinternetu

waterwall

sufak79

ntukinal

Miguelcnc

Forum Stats:

Groups: 10

Forums: 185

Topics: 6037

Posts: 60500

 

Member Stats:

Guest Posters: 43

Members: 262194

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix