Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
Chuwi V17HD Gen1 troubles
Dead WiFi, tablet suicided, now dead RAM too?
Avatar
xan1242
New Member
Forum Posts: 1
Member Since:
2017/04/07
sp_UserOfflineSmall Offline
1
2017/04/07 - 01:17
sp_Permalink sp_Print sp_EditHistory

Hello there! I'm not a newcomer to the Rockchip tablets, but this thing takes the cake for being the utmost annoying thing I've ever repaired. This one in particular is actually a rebrand of the Chuwi V17HD Gen1 in Croatia by H18 (Mytab something I can't remember honestly). It has direct root access and developer settings enabled by default, which is bad for security reasons.

Essentially I was in the process of finding out and testing why the wifi module didn't work - firmware didn't want to load. The chip is a NM1000AA, firmware NMI1000.

To rule out any hardware mishaps, I resoldered the antenna and cleaned up around the chip with some flux. After reassembling, the device still didn't want to turn wifi on, same errors, except this time around sometimes after formatting /data and /cache it got stuck in a bootloop at random times, but most of the times it booted up. Sometimes it said "Turning on Wi-Fi..." in the settings, other times it got stuck during scanning (timing out most of the time).

So after that, I decided to try some software trickery. I checked the firmware files inside /system/etc/firmwares (IIRC) and they all seemed fine. So the only other option was to try another Android ROM. In the process of downloading Oma's custom roms, I decided to put the tablet to charge. And so it charged, and charged, and charged...

TLDR; - read below

I check one time, 32% charged, other time 64% charged, third time I booped the power button... No cigar. Blank screen. So I unplug it from my computer (was in Windows 10) and I hear the disconnect from Windows. I hit the reset button on the tablet, nothing. I tried bootloader mode, nothing. I unplugged the battery, discharged the device completely, replugged the battery in and still dead. I was like, oh crap, what now? Then I decided to reflow the VRM, nothing.

After doing so, I decided to plug in the RS232 interface and see what it outputs. Lo and behold, I got some clues:

 

DDR Version 1.04 20140304

In

DDR3

300MHz

init failed

ERR

 

This led me to believe the RAM had died (the chip is a PL023-25BT by some chinese manufacturer), so I reflowed that chip and the results are still the same. Not to mention that the RAM, the SOC, NAND flash and the RK616 are heating up too while holding the power button/plugged in USB.

The only other option that remains for me is to replace the RAM chip with another one if I can find it. (and even then it's not that safe if the replacement will work, BGA resoldering stinks with just a reflow station and nothing else)

RAM chip itself

This is REALLY unlucky and I'd have to get this repaired (not mine), so if anybody has any ideas, please tell me what to do.

 

EDIT: Oh, sorry for posting here! Didn't browse the forums much (kept crashing). If mods want, please, move this post to Chuwi forum! :v

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online:
107 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (95), Phone (10), Tablet (2)

Top Posters:

Oma7144: 6315

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 432

maikal: 394

Newest Members:

delucrob

rami21

rustev

Timak

Kaidoz

kyazid

Forum Stats:

Groups: 10

Forums: 185

Topics: 5991

Posts: 60327

 

Member Stats:

Guest Posters: 43

Members: 259874

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix