Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
Need help for WIFI and battery management activation (AOSP ROM)
AOSP mod for WIFI and battery mangement
Avatar
Dick Tracy
New Member
Forum Posts: 1
Member Since:
2015/03/27
sp_UserOfflineSmall Offline
1
2015/03/27 - 12:25
sp_Permalink sp_Print

Hello, need help for WIFI and battery management activation.
Tablet: Vero A8839, greek local brand, presumably clone of Yifang M8003KP (I have read under the cover OKM 8003KP M8003KP)
Brand owner: oktabit.gr, support forum forum.oktabit.gr/topic/vero-tablet-a8839-8-dual-core-ips
About a month ago I made tablet bricked and succeded in it’s revival by switching in “mask mode” (locked 8 and 9 pin on NAND flash chip).
I asked help in support forum, moderator gave me the link to RAR-archive with firmware but it turned broken. RAR Recovery ToolBox didn’t help. Moderator of support forum wrote that he didn’t have other firmware for my tablet.
I succeded in extracting only boot.img, misc.img, recovery.img and specification file readme.txt (in chineese) from RAR-archive.
After some experiments with analog devices I tried to port CrewRKTablets_RK30_Genio by Oma_AOSP_4.2.2_v3.4 using stock boot kernel. It works fine but two problems are still exists:
1) battery management - says that battery are empty at the moment when it is just half-empty and doesn’t show charging status for half an hour after plugging-in to charger
2) WIFI is not working
Although AOSP ROM contains rt5370 driver, wlan0 service doesn’t communicate with wpa_supplicant (I think so).
I tried CM10.1 ROMs but they don’t contain rt5370 drivers at all. When I just add them (rt5370sta.ko and rt5370ap.ko) to /system/lib/modules and rt5370sta.dat and rt5370ap.dat to /system/etc/firmware – nothing changes. I think that both modules rkwi.ko, wlan.ko and libhardware_legacy.so also must be changed.
May be somebody knows the better way (better ROM) to make WIFI and battery management work properly?
Attachment is archive with stock boot.img, misc.img, recovery.img, logs (logcat and dmesg) and specification readme.txt

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online: EricGTS5570
200 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (172), Phone (29)

Top Posters:

Oma7144: 5664

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 430

maikal: 394

Newest Members:

vrata

kho

tps4

max4max

zabmrano2023

k3030_01

Forum Stats:

Groups: 10

Forums: 185

Topics: 5884

Posts: 58444

 

Member Stats:

Guest Posters: 43

Members: 255399

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix