Forum switched to read-only as of 2020/06/01


Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
PiPO M9 PRO GPS performance ?
Avatar
ludoke
Regular Member
Forum Posts: 85
Member Since:
2013/10/26
sp_UserOfflineSmall Offline

Thanks Received: 3
166
2014/01/22 - 18:24
sp_Permalink sp_Print

skippie said
on finless : sees 4 says but none is on use. 

 

What am I doing wrong? Am I close to have it working? 

 

Did you delete the file ? Are you waiting long enough the first time to get fix.

Whitch navigation app do you use?

The best way to know is with GPS test because TomTom ,Sygic and Copilot have all different times to get a fix.

I'm now on 10 in view and 6 in use and this is indoors.

 

Avatar
skippie
Member
Forum Posts: 17
Member Since:
2013/02/08
sp_UserOfflineSmall Offline
167
2014/01/22 - 18:43
sp_Permalink sp_Print

yes i deleted the file : gps.conf and replaced with the uk conf.

 

I am using sygic and using GPS test.

Avatar
ludoke
Regular Member
Forum Posts: 85
Member Since:
2013/10/26
sp_UserOfflineSmall Offline

Thanks Received: 3
168
2014/01/22 - 19:03
sp_Permalink sp_Print

skippie said
yes i deleted the file : gps.conf and replaced with the uk conf.

 

I am using sygic and using GPS test.

You dont have to delete the config files ,read post 164 and in data/gps delete the file named gldata.sto file.

You need root also . Do you have read the post ?

 

Avatar
skippie
Member
Forum Posts: 17
Member Since:
2013/02/08
sp_UserOfflineSmall Offline
169
2014/01/22 - 19:05
sp_Permalink sp_Print

yes i got rooted rom Finless and i deleted gldata.sto also

 

it sees the sats (4 maximum) but none is in use.


Avatar
ludoke
Regular Member
Forum Posts: 85
Member Since:
2013/10/26
sp_UserOfflineSmall Offline

Thanks Received: 3
170
2014/01/22 - 19:09
sp_Permalink sp_Print

skippie said
yes i got rooted rom Finless and i deleted gldata.sto also

 

it sees the sats (4 maximum) but none is in use.

How long did you wait? Test it in GPS test and wait for the first fix about 15 mins.

I have now 12 in view and 9 in use ,m9 Pro

 

Avatar
lew247
New Member
Forum Posts: 9
Member Since:
2013/11/04
sp_UserOfflineSmall Offline

Thanks Received: 1
171
2014/01/22 - 19:23
sp_Permalink sp_Print

I deleted the file
and still nothing

no satellites at all no matter what I try

The GPS is turned on (or so it says) using GPS test and the GPS Status

I left it in a window with a clear view to the sky for 30 minutes and nothing

Avatar
ludoke
Regular Member
Forum Posts: 85
Member Since:
2013/10/26
sp_UserOfflineSmall Offline

Thanks Received: 3
172
2014/01/22 - 19:40
sp_Permalink sp_Print sp_EditHistory

lew247 said
I deleted the file
and still nothing

no satellites at all no matter what I try

The GPS is turned on (or so it says) using GPS test and the GPS Status

I left it in a window with a clear view to the sky for 30 minutes and nothing

Do you have M9 PRO ,apparently there are tablets with bad antenna fix inside the tablet.

Before the fix i discribed i got a fairly fix with NTPsync,but after this fix it's really good.

I think it's batch related. Did you ever had a fix before? I mean nothing or a little ?

I get my fix even indoors. Finless 1.5?

Is your time setting correct? very important , set your regio where you live.

 

 

Avatar
lew247
New Member
Forum Posts: 9
Member Since:
2013/11/04
sp_UserOfflineSmall Offline

Thanks Received: 1
173
2014/01/22 - 19:53
sp_Permalink sp_Print

Finglas 1.5

No I never had a fix at all

When it was on the original rom I saw one satellite once for a few moments but then nothing

 

I'm thinking about getting a gps antenna out of a Galaxy phone and putting it inside the tablet but I need to be certain which is the gps antenna cable

I saw the pictures and there are 2 antenna cables and which one it "should be"

But can anyone confirm which definitely 100% is?

Has anyone tried putting a different gps antenna inside out of a phone or another tablet? or thought about doing it?

 

Avatar
Viljar70
New Member
Forum Posts: 3
Member Since:
2014/01/07
sp_UserOfflineSmall Offline
174
2014/01/22 - 20:29
sp_Permalink sp_Print

Viljar70 said
I have a PIPO M7 Pro (3G) (running: kasty-pipo-m7_pro-422-ota_106_20131130.img)
and also the same problem - It can find max 1-2 satellites and never fixes a location.

I tried the gps.conf file (modified it for Estonia) but it did nothing for Me, if anything, made it worse..

also tried to use the GPS-HELP-File-Auto-install-via-ADB.zip but it said Device Not Found  

Tried the NTPSync program - nothing

Should I try to copy over the other files (like in the GPS-HELP-Files_FINLAND.zip - posted on Page 6 of this thread)

Any other suggestions ?
Edit: Here is a video of how to resolve the M9 WiFi connection and reception issues:
Wonder, if same method could be used to fix the GPS issue ?!
I would use coax cables for both wires tho (using only middle strand)

AnyOne ?!

Avatar
lew247
New Member
Forum Posts: 9
Member Since:
2013/11/04
sp_UserOfflineSmall Offline

Thanks Received: 1
175
2014/01/22 - 20:52
sp_Permalink sp_Print

Forgot to say its the M9 Pro

Avatar
skippie
Member
Forum Posts: 17
Member Since:
2013/02/08
sp_UserOfflineSmall Offline
176
2014/01/22 - 21:16
sp_Permalink sp_Print sp_EditHistory

did the whole ADB setup now but :

 

screen : doesn't go landscape anymore

wifi : not working

 

GPS : testing now

UPDATE : as wifi is not working, GPS doesn't work either

 

So result : i have to reinstall Finless 1.5 now ?

Avatar
Mobius48
Member
Forum Posts: 12
Member Since:
2013/11/05
sp_UserOfflineSmall Offline

Thanks Received: 4
177
2014/01/24 - 16:05
sp_Permalink sp_Print

ludoke said

Mobius48 said

ludoke said
People,

I believe this is the solution for the GPS issue,i have tried it en it's working for me

Thanks to manao from Freaktab !!!!

 

Regarding the GPS, I would like to share a little information.
Chinese dealers test the GPS before shipping your tablet.

If you look in the folder root /data / GPS you will see that there is a gldata.sto file.
This file is created at the first use of your GPS, but as it has been tried before in China, the gldata.sto (glonav data?) Is configured for China...

Just simply remove gldata.sto file and reboot. This file will be created again at the first use of your GPS and will be modified each time you use your GPS.

The gps.conf file is useless with the latest Pipo models.

For the first fix, you must hold the tablet vertically, connectors at right.

 

Forgive my ignorance, but I do not see the folders specified.  I see folder Android / data but no GPS and no gldata.sto file.  Does the tablet need to be rooted first? 

Yes,it must be rooted ,without root you have no entry to those files you have to root and install root explorer or ES explorer.

And i can tell,it's WORKING after the first fix (takes a while) fix in secs, INDOORS

Apparently the tablet does not need to be rooted to access this file.  I installed "fx" file explorer  and then installed "fx (root)" add-on.  I can now access the root files.  If this file gets updated each time you get a GPS fix, then I'm not sure what good it would do to erase the factory copy.

 

Avatar
ludoke
Regular Member
Forum Posts: 85
Member Since:
2013/10/26
sp_UserOfflineSmall Offline

Thanks Received: 3
178
2014/01/24 - 16:25
sp_Permalink sp_Print

Mobius48 said

ludoke said

Mobius48 said

ludoke said
People,

I believe this is the solution for the GPS issue,i have tried it en it's working for me

Thanks to manao from Freaktab !!!!

 

Regarding the GPS, I would like to share a little information.
Chinese dealers test the GPS before shipping your tablet.

If you look in the folder root /data / GPS you will see that there is a gldata.sto file.
This file is created at the first use of your GPS, but as it has been tried before in China, the gldata.sto (glonav data?) Is configured for China...

Just simply remove gldata.sto file and reboot. This file will be created again at the first use of your GPS and will be modified each time you use your GPS.

The gps.conf file is useless with the latest Pipo models.

For the first fix, you must hold the tablet vertically, connectors at right.

 

Forgive my ignorance, but I do not see the folders specified.  I see folder Android / data but no GPS and no gldata.sto file.  Does the tablet need to be rooted first? 

Yes,it must be rooted ,without root you have no entry to those files you have to root and install root explorer or ES explorer.

And i can tell,it's WORKING after the first fix (takes a while) fix in secs, INDOORS

Apparently the tablet does not need to be rooted to access this file.  I installed "fx" file explorer  and then installed "fx (root)" add-on.  I can now access the root files.  If this file gets updated each time you get a GPS fix, then I'm not sure what good it would do to erase the factory copy.

 

I'm also not sure about that but it has clearly helped for me,so i'm happy

 

Avatar
cracktech
Malaysia

Moderator
Forum Posts: 432
Member Since:
2013/01/24
sp_UserOfflineSmall Offline

Thanks Received: 112
179
2014/01/24 - 16:45
sp_Permalink sp_Print

I am cluless about the GPS fix issues already but you all can try anything thats put forward except that my advise is not to touch anything in the "gpsconfig.xml" statements, I have tried with disastrous results. keep the original somewhere safe before trying to modify this "*.xml" file. good luck.

About Me    LENOVO S939 MTK6592 Vibe 2.0 - 1507,LENOVO A8-A5500 KitKat MTK8382 S029,Lenovo Tab2 A7-30HC MT8382 Lollipop,LENOVO A880  S027 MTK6582 (JB),ONDA V975m V3 AMLOGIC M802 (KitKat)PiPo M9Pro RK3188 KASTY ROM (KitKat # 407 Mod), ZENITHINK ZTPAD:C93 Duo Core AMX CM10.2_rc-3, Z102 And. 4.0.4, C91 And. 4.0.4,AIGO M60 Android 4.04 6" A13 (rooted).Lenovo A369i 4.2.2 S011 ROW

 

Avatar
Mobius48
Member
Forum Posts: 12
Member Since:
2013/11/05
sp_UserOfflineSmall Offline

Thanks Received: 4
180
2014/01/28 - 02:50
sp_Permalink sp_Print

I know this thread is primarily about making the internal GPS work but I thought I would offer another solution.  I use GPS to send location monitoring packets over a ham radio so having an antenna on top of the vehicle is the best solution for visibility.  The cord from the antenna is thin enough to fit through the weather stripping of the vehicle door without being crushed.  I use a GlobalSat model BU-353 USB GPS that has a magnet on the bottom side.  It plugs into the PiPo adapter and then into the Host USB port.  I found that I had to install and run an app called USB GPS in order to collect the data from the USB port.  Set the speed to 4800 baud in the app and set the option to let the USB GPS replace the internal GPS or just turn off the internal GPS.  If you want to see the NEMA data messages, an app called You Are Here GPS will work.  I have tested this setup with Google Maps and it works.  I also tested it with GPS Test (the free version) but that software doesn't seem to be able to read the data from the GPS.

Forum Timezone: Europe/Paris

Most Users Ever Online: 803

Currently Online:
51 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (45), Phone (6)

Top Posters:

finless: 604

DarthJabba: 551

maikal: 394

mussonero1: 350

alex: 252

damo: 243

DanielVd: 237

Mark06: 222

Newest Members:

thanhgom2006

hoholms

rammaiden

iongeorge411@gmail.com

legrandhommer

mindra

Forum Stats:

Groups: 10

Forums: 185

Topics: 6037

Posts: 60500

 

Member Stats:

Guest Posters: 43

Members: 262194

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix