Latest product reviews
ARCHOS 50 Diamond
TV Connect


Please consider registering


— Forum Scope —

— Match —

— Forum Options —

Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[ ROM ] Onda V972 (V3 hardware) Android 4.2.2 Jelly Bean root custom firmware V3.3.1 (2013-11-22)

Forum Posts: 5871
Member Since:
sp_UserOfflineSmall Offline

Thanks Received: 3163
2013/11/23 - 21:02
sp_Permalink sp_Print
Here is latest Android 4.2.2 Jelly Bean update for the Onda V972 tablet (hardware V3) based on newest Onda firmware release version 3.3.1 published 2013/11/22.

Manufacturer revision history: (translated from Chinese)
1 new boot logo 

2. new Onda desktop 

3. underlying SDK upgrades, system stability and compatibility enhancements 

4.Miracast function optimization 

5. system comes with software to increase multi-language support 

6. fixes known software issues 

7 Set – stored under the new built-in disk total capacity display Note: 1, the firmware package containing Brush tutorial and Brush tool, use desktop computers Brush; 2, Brush risk, please before Brush carefully read the tutorial; 3, the V2 firmware version applies only to models; 4, check the version number, see the back of the fuselage SN code 9,10 bit;

Firmware build information:

Linux Kernel: Linux version 3.3.0 (onda@SRV2013) (gcc version 4.6.3 20120201 (prerelease) (crosstool-NG linaro-1.13.1-2012.02-20120222 - Linaro GCC 2012.02) ) #1 SMP PREEMPT Mon Nov 18 05:37:44 UTC 2013

Android system: onda/fiber_onda978q9p663/fiber-onda978q9p663:4.2.2/JDQ39/20131119:eng/opinions-on-teclast-p90hdst-keys


Our rooted custom firmware features:

  • root with latest SuperSU 1.75 (free version)
  • system default setup English
  • removed most Chinese and unnecessary applications
  • Google Play Store fixes so more application are visible/compatible
  • updated busybox v1.21.0.git (2012-11-29)
  • Unix like init.d boot scripts support, more details on init.d scripts here
  • changed permissions on external sdcard to allow write access
  • removed Onda new launcher
  • optional Team Win Recovery Project (TWRP) easy install package
  • New! kernel modules (USB GPS, Xbox/PS3 gamepads, OpenVPN,…) compiled by Christian Troy, thank you. See our guide for XBOX 360 gamepad support
Flash with PhoenixSuite (tutorial)


After flashing the tablet, a Setup Wizard may appear on first boot to configure your network, regional settings, etc… If the wizard does not appear, just disconnect your USB cable from the tablet, make a short press on the power button to turn off the screen. After the screen is turned of, press the power button for a short time again to power the tablet, the Setup wizard should now be displayed.

Please report any problem with this firmware, I can't verify this custom firmware works as I don't have an Onda V972 (v3) tablet to test the custom firmware.  

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

New Member
Forum Posts: 1
Member Since:
sp_UserOfflineSmall Offline
2014/01/17 - 03:34
sp_Permalink sp_Print

HI, I've just tried for few hours this new fw..I have noticed two problems: youtube is impossible to use, very long buffering and impossible to watch! The other problem is with some games like asphalt, because of various lags. I'm the only one with these problems?

New Member
Forum Posts: 9
Member Since:
sp_UserOfflineSmall Offline

Thanks Received: 2
2014/04/16 - 11:44
sp_Permalink sp_Print

Thanks, plase onda v972v2 4.4.2 kasty rom. 

New Member
Forum Posts: 1
Member Since:
sp_UserOfflineSmall Offline
2014/11/02 - 21:26
sp_Permalink sp_Print

can you tell me why I can't turn the WiFi on?


Forum Posts: 430
Member Since:
sp_UserOfflineSmall Offline

Thanks Received: 111
2014/11/04 - 15:01
sp_Permalink sp_Print

As far as I know (since I faced similar problems on various apps YouTube/Hangouts/Maps) on many devices running Android 4.2.2 and 4.4.2 in this interim period between Android KitKat and Android L, it is because first and foremost you must update GmsCore.apk (GApps) then update (if having problem with YouTube) to update YouTube to latest version from "Aptoide Market". (Google for the "Aptoide".apk). and update from my attached file (unzipped it and sideload) Aptoide Market normally will be 1 version ahead of GooglePlaystore version.

If this still fails what me and my users have found out (yes! I cooked a lot of ROMs 4.4.2) is to "RootUninstall" the offending Gapps (YouTube/Hangouts/Maps) and redownload it back from Playstore/or better Aptoide (the latest Playstore version is not what Playstore pushes to you some of you might be 2 versions behind visit Aptoide). That will definitely solved your YouTube/Hangouts/Maps problems I have the worst problems with GooglePlus if it is included in the ROM to the point that I installed it as after market app from Playstore. (This is due to the fact that it always requires the GmsCore to be updated first before it can run)

Before the latest GmsCore update we had problems with Hangouts FC until this latest version (attached file).As I mentioned earlier this is the interim period between KitKat and L so developers optimised their apps to skew towards either one or the other.

As for the ONDA WiFi problems you will need to format your internal sdcard before flashing the new ROM but there are no guarantees as my ONDA V975m has the worst WiFi performance out of my 7 pads that I own (it keeps losing internet connections but not wifi connections every now and then) ONDA devices have very bad kernel binding for WiFi and until some superguru can decode the kernel to make the wifi better we are left with tjis problem I had to install install "KeepWiFiOn" and "Auto start wifi" in the interim. But you should clean up dalvik-cache/cache and format your internal sdcard before flashing a new ROM if you faced this problem. (Backup 100% your data first).

Good luck!

About Me    LENOVO S939 MTK6592 Vibe 2.0 - 1507,LENOVO A8-A5500 KitKat MTK8382 S029,Lenovo Tab2 A7-30HC MT8382 Lollipop,LENOVO A880  S027 MTK6582 (JB),ONDA V975m V3 AMLOGIC M802 (KitKat)PiPo M9Pro RK3188 KASTY ROM (KitKat # 407 Mod), ZENITHINK ZTPAD:C93 Duo Core AMX CM10.2_rc-3, Z102 And. 4.0.4, C91 And. 4.0.4,AIGO M60 Android 4.04 6" A13 (rooted).Lenovo A369i 4.2.2 S011 ROW


Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online: PrEzi, Sawbones, Bahramz
203 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Devices in use: Desktop (163), Phone (40), Tablet (3)

Top Posters:

Oma7144: 5723

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 430

maikal: 394

Newest Members:






Forum Stats:

Groups: 10

Forums: 185

Topics: 5897

Posts: 58630


Member Stats:

Guest Posters: 43

Members: 255762

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech

CrewRKTablets moderators: JochenKauz and Astralix