Latest product reviews
ARCHOS 50 Diamond
TV Connect


Please consider registering


— Forum Scope —

— Match —

— Forum Options —

Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
Onda V711s quad-core Version _v3.2.1_v3 Official Firmware
New Member
Forum Posts: 2
Member Since:
sp_UserOfflineSmall Offline

Thanks Received: 2
2013/11/13 - 23:06
sp_Permalink sp_Print sp_EditHistory

Hello everyone,

I just got my tablet  ONDA V711S V3 MODEL  today.

As always ordered from with 0 customs fees and delivery in 4 days via DHL for 5 euros.

The original firmware is : v3.2.1_v3  CN Server 
or  FR Server 

And here PhoenixSuit 1.05 English to flash the rom.

What is important is the V3 and yes it's brand new ... but there is a method for rooter beast.

Download here ROOT A31 :

Then in the local memory use and the application of origin " UPDATE" and flash the file


Below is a tutorial to update your tablet with PhoenixSuit 

Where to find the latest versions :
For onda is here: section news on onda -tablet 
Please note , take the appropriate firmware to the version of your tablet 

Prerequisites : 
1 - use WinXP, Win7 system, connected to the USB port on the computer USB cable.
2 - Make sure the tablet is more than 50 % battery
3 - disable anti -virus software on your computer ( antivirus software can interfere with or block the processuce ) .
4 - Having downloaded the zip update (firmware )

1 - Remember to make a backup before updating , so be sure to remove the microSD card ;
2 - Read the instructions before the shift , there is always a risk of malfunction , this is here to help , thank you not to hold me or the forum for any problems occurred during installation ;
3 - The driver is not installed correctly, the device manager shows: Please uninstall the drive and reinstall ;
4 - If the Update fails, disconnect the USB cable and press the power button for about 20 seconds to force the tablet to stop and then start step tutorial 3.1;

1 - extract the downloaded firmware , the following figure shows : 

You will find three files : a tutorial in Chinese word , an image file ( this is the shift in question) , and the installation file PhoenixSuit 
 980372891.pngImage Enlarger


2 - Install PhoenixSuit tool : 
In the extracted folder , double -click the installation file PhoenixSuit , follow the steps below: 
In this step , a pop-up window may open . In this case, click the following window, or press the button to continue to install the driver: 
At the end of the installation, a shortcut icon is created on the desktop. 
Firmware installation will be able to start !

3 - PhoenixSuit run the tool , start flashing  Firmware : 

3.1  Double- click PhoenixSuit which is now on the desktop ( or via the Start menu) icon, the following interface appears:
 If a small window opens (updated software ), be sure to close 

3.2  Go to the tab selection firmware by clicking on the anchor. After selection of the firmware, press the green button.
Help yourself steps below to select your downloaded firmware ( image file) 

3.3 Tablet PC first. If you can not determine if the shutdown state , you can press the power button for 10-20 seconds to force shutdown .

3.4  Home button on the tablet ( with the printed side with a small house icon button) hold , connect the USB cable, then press and hold the power button 5-10 times bottom corner until you are asked to find new hardware and install the driver ( window at the bottom right of the computer screen ), release the Home button , as shown below and install correctly driver: 
Tips :
a. automatically appear repeatedly in a new window hardware , the driver is automatically installed ;
( b) If the driver is not installed automatically , you can manually update the path to the installation directory . The default path is C: Program Files AllWinnertech PhoenixSuit Drivers AW_Driver ... ;
c . If you use the computer that you already used to install a SHIFT , this step is not necessary 

3.5 Once recognized tablet, just follow the instructions below: 
With this, the upgrade is complete.
Close the tool update , disconnect the cable , USB tablet manual start . After the update is complete, the first starting time will be longer, please be patient for a while. 


Sorry for my English that Thx Google Translate

The following users say thank you to cake1974 for this useful post:

mickaculous, irishpancake
Forum Posts: 11
Member Since:
sp_UserOfflineSmall Offline
2013/11/15 - 12:45
sp_Permalink sp_Print

Thanks for that, not much stuff around in terms of tutorials for v711s. Most of this i discovered by trial and (alot of) error!


Forum Posts: 5871
Member Since:
sp_UserOfflineSmall Offline

Thanks Received: 3163
2013/11/15 - 13:28
sp_Permalink sp_Print

In case you missed it we have a tutorial for PhoenixSuite


If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

New Member
Forum Posts: 2
Member Since:
sp_UserOfflineSmall Offline
2014/01/30 - 04:48
sp_Permalink sp_Print sp_EditHistory

I cant get my onda v711s v3 to connect to pheonix suite debug is checked......i installed your root beast via local update but could not get internet after getting root there any other way i can get rid of chinese apps.....finallly got wifi back working after factory reset...thought i had bricked device....any help will be greatfully received.


factory reset the device and started from scratch....rooted my v711s (hardware version v3) through local update again this time worked swimmingly......delete those pesky Chinese apps.

Still can't get my device connected to Phoenix suite, but don't care as all is now well Cool


Thanks uploader and sorry for any negativity on my part

New Member
Forum Posts: 1
Member Since:
sp_UserOfflineSmall Offline
2014/03/15 - 01:40
sp_Permalink sp_Print sp_EditHistory

Thanks to cake1974 man, for the Root method.


Like you, I got the v711s V3........also from Hongkonggeek!!


no customs to pay, really good service, good tracking, etc.


this "rooter beast" method worked first time!!


This is Android 4.2.2


Firmware version is V3.2.5_V3


Newer F/W here:


Or faster here:




V4.4_v3 [KitKat Beta]

New Member
Forum Posts: 1
Member Since:
sp_UserOfflineSmall Offline
2016/01/01 - 02:47
sp_Permalink sp_Print

What's the difference between V1/2 and V3? And how do I know which onw I have?

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online: Symber, emiliopg, Fitzcarraldo, dhalus
251 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Devices in use: Desktop (206), Phone (46), Tablet (3)

Top Posters:

Oma7144: 5723

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 430

maikal: 394

Newest Members:







Forum Stats:

Groups: 10

Forums: 185

Topics: 5899

Posts: 58642


Member Stats:

Guest Posters: 43

Members: 255827

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech

CrewRKTablets moderators: JochenKauz and Astralix