Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
iFIVE X2 video glitches on Android 4.4.2 KitKat firmwares
Avatar
rwanek
New Member
Forum Posts: 9
Member Since:
2013/09/18
sp_UserOfflineSmall Offline

Thanks Received: 3
1
2014/01/28 - 12:27
sp_Permalink sp_Print sp_EditHistory

admin said
I am curious to see how these glitches look, I am not sure this has been shown in a video so far, can anyone record these glitches happening and upload them here or on Youtube ?

Cheers.

 

Hi, just made short video, short after unlocking the tablet this flickering appears - sorry for the quality, it was taken with blackberry camera.

anyway, this shot flickering is the small one, sometimes i get glitches that whole screen is unreadable, but on the video you can see that screen flickers, there are double or triple icon images, etc...

I'm on kasty 2.0.0 kitkat, tablet was bought on Oct 2013.

 

 

Admin edit: Initially published at http://www.arctablet.com/blog/forum/fnf-ifive-tablets/rom-fnf-ifive-x2-android-4-4-2-kitkat-custom-rooted-firmware-based-on-v2-0-0-20140108/page-13/ was moved to a separate topic.

The following users say thank you to rwanek for this useful post:

admin, Abubacker
Avatar
admin

admin
Forum Posts: 5871
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
2
2014/01/28 - 12:41
sp_Permalink sp_Print

Thanks for making and posting the video rwanek, I finally see how the glitches are looking as I don't own an iFive X2 to check the problem. All I can say for now is I haven't seen such display issue on the other KitKat firmwares I have tested so far on RK3188 based tablets: PiPO M6 Pro / M7 Pro and M9 Pro.

 

Cheers.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
TecKnight
Las Vegas, NV

Contributor
Forum Posts: 91
Member Since:
2012/11/04
sp_UserOfflineSmall Offline

Thanks Received: 20
3
2014/01/28 - 12:56
sp_Permalink sp_Print sp_EditHistory

Hi, just made short video, short after unlocking the tablet this flickering appears – sorry for the quality, it was taken with blackberry camera.

anyway, this shot flickering is the small one, sometimes i get glitches that whole screen is unreadable, but on the video you can see that screen flickers, there are double or triple icon images, etc…

I'm on kasty 2.0.0 kitkat, tablet was bought on Oct 2013.

rwanek,

I know that admin really appreciates your time and effort in creating and uploading this video, as do I.

I was hoping you could clarify when you typically see the glitches. You indicated it starts shortly after unlocking the tablet.

When you say unlocking, are you referring to:

1. unlocking the tablet by pressing the top left button after the screen is blanked to save power (you are causing tablet to emerge from suspend mode)

or

2. unlocking the tablet by activating the slide lock or other configured startup widget, when it is presented. (this satisfies the screen lock conditions, allowing the Android boot process to proceed)

Again, thanks for taking the time.

Avatar
admin

admin
Forum Posts: 5871
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
4
2014/01/28 - 13:01
sp_Permalink sp_Print

I have moved some posts here, please use this topic for glitches related question for the iFive X2 KitKat firmwares, thanks.

 

Cheers.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.


Avatar
rwanek
New Member
Forum Posts: 9
Member Since:
2013/09/18
sp_UserOfflineSmall Offline

Thanks Received: 3
5
2014/01/28 - 13:12
sp_Permalink sp_Print sp_EditHistory

TecKnight said

Hi, just made short video, short after unlocking the tablet this flickering appears – sorry for the quality, it was taken with blackberry camera.

anyway, this shot flickering is the small one, sometimes i get glitches that whole screen is unreadable, but on the video you can see that screen flickers, there are double or triple icon images, etc…

I'm on kasty 2.0.0 kitkat, tablet was bought on Oct 2013.

rwanek,

I know that admin really appreciates your time and effort in creating and uploading this video, as do I.

I was hoping you could clarify when you typically see the glitches. You indicated it starts shortly after unlocking the tablet.

When you say unlocking, are you referring to:

1. unlocking the tablet by pressing the top left button after the screen is blanked to save power (you are causing tablet to emerge from suspend mode)

or

2. unlocking the tablet by activating the slide lock or other configured startup widget, when it is presented. (this satisfies the screen lock conditions, allowing the Android boot process to proceed)

Again, thanks for taking the time.

 

no problem - those glitches appear after unlocking/ waking up from suspend mode tablet after long time of no use, f.e. if i don't use it for more than one hour, i wake tablet with smart cover, or by short pressing power button (doesn't make difference which method of waking - I have a PIN security, but changed it to slide unlock - no change, still glitches) those glitches appear (after about 3-4 seconds), strange thing is that if I quickly open fe. tapatalk i get no glitches at all, and if I use tapatalk for couple of minutes and than get back to launcher i'm good - glitches free. but if i not open quickly tapatalk i get double, triple image, glitches, artifacts, and only several power-button-locking un-locking get rid of those, no rules, sometime it's enough to just lock, wait 5sec, unlock and glitches are gone, sometimes need to do this several times.

really strange - i guess it's hardware related as there are no rules to replicate identical behavior , every time glitches are different.

 

what's important - I never get any problems, glitches on lock screen PIN or slider

The following users say thank you to rwanek for this useful post:

TecKnight
Avatar
TecKnight
Las Vegas, NV

Contributor
Forum Posts: 91
Member Since:
2012/11/04
sp_UserOfflineSmall Offline

Thanks Received: 20
6
2014/01/28 - 14:01
sp_Permalink sp_Print sp_EditHistory

rwanek,

Thanks for confirming my suspicions. It makes more sense to me that way.

Normally computer systems (even smaller ARM based devices) are pretty consistent in how they behave.

2 identical systems with identical images applied to them will usually behave identically--and 1 given system with a specific image will usually behave identically 99 out of 100 tries.

In this case, we have a single system with a consistent image that does not seem to perform predictably over multiple wakes from a suspended state, nor does it perform predictably against an "identical" system with an identical image.

When a system exhibits such inconsistency, the cause is almost always hardware related, typically hardware that is being accessed near or beyond it's max specifications. In this case, the system could be wildly unpredictable, working perfectly 1 time, then displaying increasingly blurrier images and then ultimately reboot itself.

a systems reliabilty is probably at it's lowest when waking from suspend mode, as the hardware could very easily have any of these values outside it's specs:

--voltage

--amperage

--clock speed

--bus synchronization

and it would work as designed sometimes--but other times you could easily get a glitch that could corrupt the system DDR memory or lose sync from the DDR to the Mali 400 video processor which could easily cause the imagery shown in your video.

iFive has so far manufactured a large number of X2's over a fairly long time frame and I am sure there are some significant hardware differences between different hardware GENs. In fact, it wouldn't surprise me if the issue was found to be more profound in newer devices equipped with faster DDR or flash chips.

Maybe on the older systems, the DDR was not capable of running too fast for the MALI400, so they stayed synched, but on the new faster X2's the DDR was clocking too fast for the Mali to handle.

I purchased my iFive X2 on July 7th 2013 and I have never had any graphical issues. I am also running the overclocked kernel and all my videos show as HW accelerated in MX Video player. The only problem I have seen it that Google Goggles was quite unhappy. When I took a picture, it showed a very out of focus image and then promptly locked up. After confirming this as consistent, I uninstalled Goggles

 

 

 

 

Avatar
rwanek
New Member
Forum Posts: 9
Member Since:
2013/09/18
sp_UserOfflineSmall Offline

Thanks Received: 3
7
2014/01/28 - 14:19
sp_Permalink sp_Print sp_EditHistory

i lowered CPU max clock via no frill CPU, now have to wait a bit to see if it changes anything...

 

EDIT: it didn't solve this issue..

Avatar
ram007
Member
Forum Posts: 12
Member Since:
2013/12/29
sp_UserOfflineSmall Offline
8
2014/01/28 - 16:17
sp_Permalink sp_Print

I have the exact problem with my I five x2, I purchased mine on Jan this year. Try under clocking the GPU let's see if that solves the problem.

Avatar
olivierqc
Canada
New Member
Forum Posts: 1
Member Since:
2013/08/04
sp_UserOfflineSmall Offline
9
2014/02/05 - 17:14
sp_Permalink sp_Print

hi, My tablet has a ghost issue.  Ghost does not appear when the tablet is connected to the computer and rebooted, however the glitch comes back after a certain time when my tab is not connected.

 

Avatar
elygator
New Member
Forum Posts: 4
Member Since:
2014/01/07
sp_UserOfflineSmall Offline

Thanks Received: 1
10
2014/02/05 - 19:26
sp_Permalink sp_Print

Got the same ghosting problem (only on Kit Kat ROM). It's not as bad with manu's new ROM but but it still happens. Pushing the power button to turn off the screen and then pushing again to turn on the screen fixes it for a while, but it comes back. I tried underclocking and that helped but it still happens.

Is there anyway to change the voltages, timing and speed on the GPU and memory? There's probably some combination that will fix this problem until FNF releases a new version.

By the way, this new Kit Kat android dramatically speeds up the ifive. It will be a real improvement when this ghosting problem is fixed.

elygator 

Avatar
rwanek
New Member
Forum Posts: 9
Member Since:
2013/09/18
sp_UserOfflineSmall Offline

Thanks Received: 3
11
2014/02/17 - 10:51
sp_Permalink sp_Print

interesting observation - if I unlock the tablet in horizontal/ landscape mode those glitches never appear - so it seems they are only present in portrait mode.

Avatar
elygator
New Member
Forum Posts: 4
Member Since:
2014/01/07
sp_UserOfflineSmall Offline

Thanks Received: 1
12
2014/02/20 - 03:50
sp_Permalink sp_Print

Ghosting problem seems to be fixed with the new rom release. Anyone with the problem should try it.

Elygator

The following users say thank you to elygator for this useful post:

admin
Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online: nok, cybersolutiononline
214 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (170), Phone (34), Tablet (12)

Top Posters:

Oma7144: 5664

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 430

maikal: 394

Newest Members:

senseiandrea

resteban30

cybersolutiononline

omarbled

carlo6727

toche

Forum Stats:

Groups: 10

Forums: 185

Topics: 5884

Posts: 58439

 

Member Stats:

Guest Posters: 43

Members: 255337

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix