Forum switched to read-only as of 2020/06/01


Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[ ROM ] FNF iFive X2 Android 4.2.2 custom rooted firmware based on v1.1.5 (2013/07/23)
Avatar
fit4ugolf
New Member
Forum Posts: 1
Member Since:
2014/12/05
sp_UserOfflineSmall Offline
121
2014/12/05 - 19:21
sp_Permalink sp_Print

TecKnight said

pierre118 said
@bklm1234 Thanks for your answer!

 

But what is described I already did more than 1 time, but without any success. I still got the error 10 in the the Windows device manager on the Rockusb device. I even booted W8 with driver signing off, but makes no difference. It stays on code 10. I even tried it on my Surface Pro, but with the same result.

 

Is there another way to flash firmware on the X2, maybe from SDcard?

I hope someone can help me with this.

Pierre,

I have an idea what your issue may be.

1. Rockchip processors have a unusual property when it comes to power. If 5V external power is provided to a Rockchip based device that is powered down, the device will power itself up and attempt to boot. This means that when power is provided to your tablet by connecting it to it's adapter or to a PC's USB port, the device will immediately power up.

2. When the tablet powers up, it immediately looks to see if the volume up button is depressed and if so, it goes into a special flash mode. You will know if it is in flash mode, because the display will remain dark, in order to consume as little power as possible during the flash process. If you are seeing the boot screen on your tablet, you are NOT in flash mode.

3. Windows will see one device ID when your tablet is in flash mode and another device ID when it is not.

In flash mode, the HW ID should be:

USBVID_2207&PID_310B&REV_0100
USBVID_2207&PID_310B

It showed in Device Manager as "Unknown Device".

I am running Windows 7 64 bit, so I right clicked the Unknown Device and selected Update Driver Software and then Browse my computer for driver software.

I then browsed to:

E:Rockchip_Batch_Tool_v1.7RockusbDriverx64win7

and Windows recognised the device and installed the drivers.

Device Manager then showed a new device category:

Class for rockusb devices

and a new device:

Rockusb Device

I then launched the batchtool without even rebooting and was able to flash successfully.

 

In normal android mode, Windows detects:

2 Portable Devices of class WPD FileSystem Volume Driver that are assigned drive letters

AND

1 Other Device named ifiveX2 with the following HW ID:

USBVID_2207&PID_0010&REV_0222&MI_01
USBVID_2207&PID_0010&MI_01

I have USB debugging enabled, so I am pretty sure this is the ADB (Android Debug Bridge) device.

 

If you are actually in flash mode, but getting those driver errors, I would start by right clicking on your current non working device and select uninstall. If it gives you an option to delete the drivers then do so.

After that, right click on your PC name and select Scan for HW changes. It should redetect the device after which I suggest trying a clean install of the drivers.

Hope this helps

One last thing. This is a link to a detailed procedure that I wrote for installing Picuntu linux on a Rockchip based device and it does include some pretty detailed instructions on installing the Windows drivers.

https://www.miniand.com/wiki/Part+3-Installing+the+modified+recovery+image

 

 

 

I am hoping someone might be able to point me in the right direction. I have an Ifive X2 that is bricked...well partly bricked. I can get it into flash mode, but my PC installs it as an "Android ADB device." I know that USB debugging was selected before this issue happened.

I have it recognized in ADB, but no matter what firmware I install, the Rockchip Flash tool will not recognize the device. Is there any way without having the tablet boot, to change the USB debugging via ADB or have a PC recognize the Ifive X2 as a rockchip device and not an Android ADB device?

I have followed a few different instructions on installing drivers, but each time my PC shows it as an Android ADB device.

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online:
81 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (75), Phone (5), Tablet (1)

Top Posters:

finless: 604

DarthJabba: 551

maikal: 394

mussonero1: 350

alex: 252

damo: 243

DanielVd: 237

Mark06: 222

Newest Members:

hakhiem

jenom

kfwacky

fer30

culo1

dfrt

Forum Stats:

Groups: 10

Forums: 185

Topics: 6037

Posts: 60500

 

Member Stats:

Guest Posters: 43

Members: 262194

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix