Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
Cube U30GT doesn't start, disassambling to unbrick the tablet
Avatar
shy1
UK
New Member
Forum Posts: 2
Member Since:
2012/12/16
sp_UserOfflineSmall Offline
31
2012/12/22 - 05:37
sp_Permalink sp_Print

I bricked my mini trying to update from 1.3 firmware to 1.4, there is definately something wrong with 1.3 firmware because you can not get back into flash mode once you have a failed flash.  I found the 2 outside screws were T3, my T2 screwdriver did not grip the screws very well, T3 fitted perfectly.  Also, I tried a genuine Samsung cable for Samsung galaxy, the computer recognised the mini, but rkbatch would not see the device, I tried many times disconnect and re-connect but rkbatch would not see the mini, as soon as I changed to the usb cable that came with the mini, rkbatch saw it instantly, and it flashed fine.

I don't know if the early cube devices came with bad usb cable, but my cube is only 2 weeks old, it came with 1.3 firmware installed and it has a very good quality usb cable, much thicker than my samsung one and very well moulded ends.  I would try original cube usb cable first if you are trying to unbrick your device, because I tried for ages with my Samsung cable and I could not understand why the computer saw the cube mini connected and in flash recovery mode, but rkbatch would not see the device.  It drove my crazy.

 

Avatar
AzzyG
New Member
Forum Posts: 9
Member Since:
2012/11/03
sp_UserOfflineSmall Offline
32
2012/12/26 - 02:23
sp_Permalink sp_Print

I would also appreciate any help in getting my u30gt-H working again.
Read all the posts and tried everything but either I'm doing something wrong or its a goner!

Booting normally just gives me the white screen of death.
I can get into the Recovery menu ..
... even when i do an ADB update and it completes, it aborts the installation
Tried using the RKTool but that doesnt work anymore either (sometimes i get a blue tag but never green anymore)
Tried putting may `update.img` files onto an sdcard but the system doesnt boot off my sd card.

Guys I am really stuck and frustrated.
Any help appreciated!!

-Az-

Avatar
judgeworm
Member
Forum Posts: 11
Member Since:
2012/12/25
sp_UserOfflineSmall Offline
33
2012/12/26 - 04:23
sp_Permalink sp_Print

Is anything showing up in your devices under windows? Like unknown device or something?

 

I thought i briicked mine last night. Ended up needing to resintall  usb drivers to get the flash tool to work.

 

---JW

Avatar
judgeworm
Member
Forum Posts: 11
Member Since:
2012/12/25
sp_UserOfflineSmall Offline
34
2012/12/26 - 04:28
sp_Permalink sp_Print

I downloaded new usb drivers called RockusbDriver. Forced windows to install drivers from the AMD64 folder.

Then my tab showed up as green in the RKBatchTool UI. The rest worked as intended.

Hope something like this will work for you man. Its frustrating as hell trying to get this stuff to work.


Avatar
AzzyG
New Member
Forum Posts: 9
Member Since:
2012/11/03
sp_UserOfflineSmall Offline
35
2012/12/26 - 04:30
sp_Permalink sp_Print

Thank you for answering.

The device is found and a generic device driver is installed - "Android composite ADB Interface" under "libusb-win32 devices".

On a sidenote ... i did get the RKBatchTool 1.5 to see my device and mark the block green but when trying to flash my device with RESTORE or UPGRADE options it simply fails.  (I have tried many update.img files)

Avatar
AzzyG
New Member
Forum Posts: 9
Member Since:
2012/11/03
sp_UserOfflineSmall Offline
36
2012/12/26 - 04:31
sp_Permalink sp_Print

I have heard that it may have something to do with the quality of USB cable used - I have tried 2 and both give the same result

Avatar
judgeworm
Member
Forum Posts: 11
Member Since:
2012/12/25
sp_UserOfflineSmall Offline
37
2012/12/26 - 04:53
sp_Permalink sp_Print sp_EditHistory

Yes, I read the same thing. I tried several diffrent cables myself last night and the one that worked was a samsung data cable for my galaxy s3.

Removing your old drivers couldnt hurt at this point. Maybe try to do a search for the RockusbDriver and point to the x86 folder and force install. Mine showed up as Rock306 in my devices. I right clicked on the batch tool to make sure it was running as administrator.. Then in the batch tool it showed up as Rock306 green square with 8-4 numbers under. (no clue what these numbers are)

 

also I used kasty-cube_u30gt_h-41-110-rooted firmware for mine. I selected upgrade not restore. Then the batchtool started spamming success messages and the green box changed to yellow flashing as it was updating. Hope this happens for you to man!

 

Im a relative noob to the flashing scene. But for what its worth I forgot to mention I was able to get into the recovery tool on the tablet and did wipe the cache and tried a system restore to no avail before I figured out that USB drivers may be what I needed.

Good luck!

 

 

Avatar
AzzyG
New Member
Forum Posts: 9
Member Since:
2012/11/03
sp_UserOfflineSmall Offline
38
2012/12/26 - 05:00
sp_Permalink sp_Print

Mind if i ask, when you uninstalled your drivers, what did you see in your device manager and under what heading.

Did you just uninstall the driver and plug the cable back in and try to boot again or did you plug the cable in, hold power & + for a few seconds and then boot into a black screen (if you know what i mean)

Avatar
AzzyG
New Member
Forum Posts: 9
Member Since:
2012/11/03
sp_UserOfflineSmall Offline
39
2012/12/26 - 05:04
sp_Permalink sp_Print

If i boot into a white screen - i get drivers called "CUBE U30GT-W Gadget USb Device"

If i boot into the black screen after pwr & + i get "Android composite ADB Interface"

 

I do have kasty-cube_u30gt_h-41-110-rooted firmware

I only get green if i boo the second way -  i also am trying to use my s3 cable.

 

Feels like the answer is really close (frustratingly so)!!!

Avatar
AzzyG
New Member
Forum Posts: 9
Member Since:
2012/11/03
sp_UserOfflineSmall Offline
40
2012/12/26 - 05:07
sp_Permalink sp_Print

RK15.pngImage Enlarger

Avatar
judgeworm
Member
Forum Posts: 11
Member Since:
2012/12/25
sp_UserOfflineSmall Offline
41
2012/12/26 - 05:11
sp_Permalink sp_Print

Yes, mine said Unknown device so I knew it was being recognized my comp just didnt know what it was.

 

I had to plug mine into the ac charger and hit power and volume + to even get mine to the dead droid screen. Thats when I wiped the cache in the tablet. After I wiped cache I got unknown device. 

It wouldnt do a darn thing at my computer but give me the usb bloop (usb connected sound) then immediately the USb error sound (the sounds when you unplug your usb device)

 

Like i said tho, even when it did the bloop, debloop sound it showed up as unknown device.

 

Those rockusb drivers are the official drivers for the Rockchip inside of these tablets. Thats why I figured what the hell and tried them.

Avatar
AzzyG
New Member
Forum Posts: 9
Member Since:
2012/11/03
sp_UserOfflineSmall Offline
42
2012/12/26 - 05:16
sp_Permalink sp_Print

Again, thanks for trying to help.

 

I wonder if i could ask, just to see where your device driver sits in your device hierarchy, would it be possible for you to tell me under which header the device now sits (eg: Universal Serial Bus Controllers -> U30GT-H) or a screenshot of you device manager.

 

I think the driver must be the key!  Just have to try to figure out how to get mine there (another difference is mine is AMD 64 but there is a driver for it under rockchip)

Avatar
judgeworm
Member
Forum Posts: 11
Member Since:
2012/12/25
sp_UserOfflineSmall Offline
43
2012/12/26 - 05:18
sp_Permalink sp_Print

Rockchipusb drivers and batchtool included. This should be the download link.

 

http://tabletrepublic.com/forum/downloads.php?do=file&id=121&act=down

Avatar
judgeworm
Member
Forum Posts: 11
Member Since:
2012/12/25
sp_UserOfflineSmall Offline
44
2012/12/26 - 05:24
sp_Permalink sp_Print

It sits now under devices. Shows up as U30GT-H but last night before I flashed the firmware it was showing up as simply Rock306.

 

If you are running 64 bit system point to the AMD64 folder instead of x86!

Avatar
judgeworm
Member
Forum Posts: 11
Member Since:
2012/12/25
sp_UserOfflineSmall Offline
45
2012/12/26 - 05:30
sp_Permalink sp_Print sp_EditHistory

desk.pngImage EnlargerHere ya go. Looks like it has some issues still but the tablet seems to be working fine lol

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online:
124 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (118), Phone (6)

Top Posters:

finless: 604

DarthJabba: 551

maikal: 394

mussonero1: 350

alex: 252

damo: 243

DanielVd: 237

Mark06: 222

Newest Members:

StanJo175

subseven1979

mykyta2002

ali37

JyGanTyk

lozowski88

Forum Stats:

Groups: 10

Forums: 185

Topics: 6037

Posts: 60500

 

Member Stats:

Guest Posters: 43

Members: 262194

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix