Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[ ROM ] Odys Iron OmniRom 4.4.4 custom root firmware (2014/05/30)
Avatar
LolloPS
Active Member
Forum Posts: 28
Member Since:
2014/05/20
sp_UserOfflineSmall Offline

Thanks Received: 1
61
2014/07/12 - 21:01
sp_Permalink sp_Print

Oma7144 said
Thank you for feedback. Yes, charger.bin is the wrong one.

Did you set governor to performance before run Antutu?

HDMI works pretty well on all my tabs. Something wrong with the cable?

- Oma -

ok i tried with governor Performance and i had a score of 18838 

i don't think it's the cable because with the stock 4.2.2 rom , odys iron v.1.1 Kitkat , chuwi v88 v2.2 kitkat the hdmi it's perfect...probably something wrong with kernel ...i don't know 

Avatar
livendead
New Member
Forum Posts: 10
Member Since:
2014/07/11
sp_UserOfflineSmall Offline
62
2014/07/12 - 21:59
sp_Permalink sp_Print sp_EditHistory

Oma7144 said
Ok, kernel is now in the archive: http://crewrktablets.arctablet.com/?wpfb_dl=1913

Do a clean install of the v1.3 build incl. eraseIDB.

In CWM do a factory reset and install this fix: http://crewrktablets.arctablet.com/?wpfb_dl=1912

- Oma -

Splendid work!

The auto-rotation is working superb! Smooth transitions, and the UI is more responsive.
Minor error: When I 'tap&hold' an icon to trash it, the screen rotates upside down, preventing me from removing it, or moving it around. o.o-

WiFi caused system to freeze and reboot right after finished installing.
Bluetooth is working fine now.

I've tried Bluetooth on, restarted, WiFi on didn't work, but no crashes since the first one after clean format.
I've tried Bluetooth off, WiFi on didn't work. WiFi doesn't seem to be working still, but Bluetooth is working, where as before, Bluetooth did not work at all!

Do I need something from my old system for the WiFi?

Device screen went blank. When I plugged it into the PC, it displayed 'unknown device' (Must be due to the WiFi?). That was after it went into sleep mode (automatically turned the screen off), and I was using the Launcher3 (If that plays any role).  I had to 'reset' the device through the pinhole.
It's boot-loader mode is fine, and it's booting for about 2 minutes, before it turns off again, doesn't make it back into the system.

Thanks,
Livendead

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1377
63
2014/07/12 - 22:47
sp_Permalink sp_Print

Curious. Just test another way:

Do a clean install of the v1.2 build.

In CWM do a factory reset and install the following fixes:

- http://crewrktablets.arctablet.com/?wpfb_dl=1902

- http://crewrktablets.arctablet.com/?wpfb_dl=1912

- http://crewrktablets.arctablet.com/?wpfb_dl=1369

 

- Oma -

The following users say thank you to Oma7144 for this useful post:

livendead
Avatar
livendead
New Member
Forum Posts: 10
Member Since:
2014/07/11
sp_UserOfflineSmall Offline
64
2014/07/12 - 23:29
sp_Permalink sp_Print sp_EditHistory

Oma7144 said
Curious. Just test another way:

Do a clean install of the v1.2 build.

In CWM do a factory reset and install the following fixes:

- http://crewrktablets.arctablet.com/?wpfb_dl=1902

- http://crewrktablets.arctablet.com/?wpfb_dl=1912

- http://crewrktablets.arctablet.com/?wpfb_dl=1369

 

- Oma -

Alright, I am installing those zip in the order you put them, just in case order matters!

Auto-rotation
Tap&Hold
Bluetooth
WiFi
               All of the above is working!
Nova, Google, Launcher3 all of which are working with tap&hold.

Rebooted/ Auto-rotate

-Problem Solved-
Only problem since first reboot is, it's no longer auto-rotating, or force auto-rotating, the options are selected, but it doesn't do anything after a reboot. It worked fine first boot-up, but the reboot causing it to be stuck in 90-degrees vertical position, tall tablet.

Update 1 - I've managed to find out what setting to keep it stuck using that 'Rotate' app.
'Reverse Landscape' forces the mode appropriate for webcam use, browsing, etc.

Update 2 - After another reboot, force auto-rotate is functional again!
All that is missing is 'HDMI'.
Random 'reboot' occurred, I actually used to get that on original stock ROM, but latest stock ROM solved that issue.

Thanks so much!

Regards,
Livendead


Avatar
cftmartins
New Member
Forum Posts: 6
Member Since:
2014/04/11
sp_UserOfflineSmall Offline
65
2014/07/13 - 00:28
sp_Permalink sp_Print

Hello,

V1.3 has issues for my qilive 97r

WIFI doesn't work

Autorotation doesn´t work. Caused system to freeze and reboot right after finished installing.

 

Thanks

CM

Avatar
ti5002000
Active Member
Forum Posts: 21
Member Since:
2014/06/28
sp_UserOfflineSmall Offline
66
2014/07/13 - 00:38
sp_Permalink sp_Print

cftmartins said
Hello,

V1.3 has issues for my qilive 97r

WIFI doesn't work

Autorotation doesn´t work. Caused system to freeze and reboot right after finished installing.

 

Thanks

cftmartins said
Hello,

V1.3 has issues for my qilive 97r

WIFI doesn't work

Autorotation doesn´t work. Caused system to freeze and reboot right after finished installing.

 

Thanks

CM

install the fix that oma posted for my qilive a few posts ago...it should work..in mine work..

anyway if you could do something about the backup i asked you..thanks

Avatar
pmerrill
Active Member
Forum Posts: 23
Member Since:
2013/09/25
sp_UserOfflineSmall Offline

Thanks Received: 2
67
2014/07/13 - 01:31
sp_Permalink sp_Print sp_EditHistory

Oma7144 said

pmerrill said
I tried this build Odys Iron Omni 4.4 V1.3 on a Vido N80RK

Try again incl. eraseIDB.

Change kernel in folder rockdev/Images before flash: http://crewrktablets.arctablet.com/?wpfb_dl=1911

In CWM do a factory reset and run this fix: http://crewrktablets.arctablet.com/?wpfb_dl=1910

- Oma -

 ]]>

Oma, many thanks, it worked after I changed ro.sf.hwrotation=270 as the screen was rotated incorrectly. The camera does not work but it also does not work in stock. I'm wondering whether the connector internally has popped off but I'm in two minds to open it up for a look as I don't think I've used the camera more than once or twice. 

As a help to the "relative" newbies out there (I'm one of them). I thought I would provide a comprehensive list of the steps that I followed to do the flash. Please feel free to adjust or re-use. This is for a Yuandao/Vido n80rk 8" tablet.

  1. Download CrewRKTablets Odys Iron Omni 4.4 V1.3
  2. Download CrewRKTablets KK Omni V1.3 model fix AOC Q70S15
  3. Replace the kernel.img in rockdev/Image directory with the kernel.img from a stock n80rk tablet. In order to get this stock image you can start with a stock n80rk, root with TPSparkyRoot, install CWM and backup the kernel.img file using CWM. In case you want to skip this step, Oma has posted the kernel here and the model fix here.
  4. Copy the model fix from your PC to an sdcard that you can insert into the n80rk.
  5. Boot the n80rk and turn on USB debugging and make sure the model fix file, and any other for that matter, are on the sdcard and you can see them.
  6. Power off the n80rk.
  7. Go to the directory on your PC where you downloaded the Odys Iron Omni 4.4 rom with the replaced kernel and cd to RKDevelopTool_v1.37. This assumes you have the Rockchip Drivers installed, which can be tricky. I am running Windows 7 64 bit and did not have much problem. It is best to look through the ARCTablet forum to see how to install the drivers.
  8. Start RKAndroidTool.exe, it should start and indicate 7 files to be flashed to the tablet, which are loader, parameter, misc, kernel, boot, recovery and system. backup is not checked. At this point is should show No Found RKAndroid rock usb at the bottom.
  9. While holding down the Vol+ key on the n80rk, plug a usb cable into the tablet. You should hear the usb bing/bong sound (if you have speakers on your PC of course) and the message on the RKAndroidTool should change to Found.
  10. Press EraseIDB and the RkAndroidTool should indicate 4096 blocks cleared and there will appear a Done message to the window at the right of the table. It takes about 10 secs.
  11. Press Run and the flashing will commence. It will take about one minute and again you will see a Done message.
  12. At this point, the n80rk should reboot by itself and will boot into ClockWork Recovery.
  13. Move the highlighted bar to wipe cache partition using the Vol+/Vol- keys on the n80rk and press the power key as Enter. From memory, when you hit enter you will need to use Vol+/Vol- to select Yes to cofirm.
  14. Move the highlighted bar to wipe data/factory reset using the Vol+/Vol- keys on the n80rk and press the power key as Enter. From memory, when you hit enter you will need to use Vol+/Vol- to select Yes to confirm.
  15. Next you want to apply the patch (model fix AOC Q70S15). This can be done by selecting install zip from sdcard and then on the next menu choose zip from external sdcard and then you will see the file you loaded on your sdcard (model fix AOC Q70S15). You need to select that and then select Yes on the net screen to confirm.
  16. Once that is complete, you return to the home menu of CWM by selecting +++++ Go Back +++++ and finally selecting reboot system now. CWM popup up two screens when you select reboot system now and I just answered No to both of them, though perhaps Yes is a better answer? Maybe someone can provide guidance??
  17. I then had to change the rotation by using build.prop (get from AppStore) to modify ro.sf.hwrotation to equal 270 as the screen rotation was incorrect.
  18. That's it, now you have Android 4.4 running on an Vido n80rk.

Performance

Performance wise it's ok so far. In the past I had bad problems will all 4.2 roms in terms of laggy behaviour that got progressively worse. I noticed when running OS Monitor (get from AppStore) that rknand_buffer process would start using 5-7% of the CPU and the system would "freeze" for 10-15 seconds, so much so that the tablet was really un-useable. I'm hoping this rom will fix the problem once and for all but am worried that it may be a problem with the kernel rather than anything else, in which case I'm stuffed until a new kernel is released.

As I stated, all works except the camera. This is an entry level tablet so it does not have bluetooth, auto screen brightness, gps, compass, etc. All it has it the rotation hardware sensor.

I hope this helps, please feel free to provide feedback and I will update accordingly.

The following users say thank you to pmerrill for this useful post:

Oma7144
Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1377
68
2014/07/13 - 16:02
sp_Permalink sp_Print

One of the cores is mainly fully loaded by NAND activity. This is caused by the badly driver for SD/MMC and NAND. RK refused to improve the loader, I guess this has commercial background. So, nothing to do with the kernel or the build itself.

Both answers are NO (instructions advises: do not fix su). Otherwise you will loose su rights.

This tab should have RTL8188 wifi ... can I have a dmesg log to confirm that?

Omni_v1.3_model fix_Vido_N80RK -  http://crewrktablets.arctablet.com/?wpfb_dl=1915

- Oma -

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1377
69
2014/07/13 - 16:29
sp_Permalink sp_Print

livendead said

Update 1 - I've managed to find out what setting to keep it stuck using that 'Rotate' app.
'Reverse Landscape' forces the mode appropriate for webcam use, browsing, etc.

Update 2 - After another reboot, force auto-rotate is functional again!
All that is missing is 'HDMI'.
Random 'reboot' occurred, I actually used to get that on original stock ROM, but latest stock ROM solved that issue.

Thanks so much!

Regards,
Livendead

 

I am still not satisfied about the "behaviour" of your stock kernel. The workaround with the rotate-app is unbeautiful.
HDMI is implemented meanwhile.

When you have time, could you pls try 2 ways (leave the V88 rotation fix out):

1. build v1.2 & update v1.2.1model fix 

2. build v1.3 & model fix 

 

- Oma -

The following users say thank you to Oma7144 for this useful post:

livendead
Avatar
livendead
New Member
Forum Posts: 10
Member Since:
2014/07/11
sp_UserOfflineSmall Offline
70
2014/07/13 - 22:25
sp_Permalink sp_Print sp_EditHistory

Oma7144 said 

I am still not satisfied about the "behaviour" of your stock kernel. The workaround with the rotate-app is unbeautiful.
HDMI is implemented meanwhile.

When you have time, could you pls try 2 ways (leave the V88 rotation fix out):

1. build v1.2 & update v1.2.1model fix 

2. build v1.3 & model fix 

 

- Oma -

Greetings,

I must agree with you, the kernel has given me quite the trouble with stock firmware.

In fact the random reboots, and wake/lock screen was locking up often, is something that just happened very often on stock ROM(I've not experienced that with latest update of stock ROM although).

I've did a little research on the app pre-installed "Entropy Fixer"(Value= 256), and I believe that has made a large difference. I've had zero random reboots, and no lock/wake lockups, reboots, or crashes since I put the value to 256. Do you suggest a certain value, and can you confirm if this is wise for me to do?
Default entropy is "64",These values for the Entropy Fixer were on the Omni v1.2 ROM so far only tested.

Test v1.3 - Right now I have confirmed that WiFi is not working, it causes system to shut down right after first flash boot-up, after 4 restarts the same thing, and after trying various methods, like Bluetooth first, restarting, coming back, etc. All of which will not turn on WiFi.

Auto-rotation sensors is working fine!
Although rotation is 'partially' working, when in landscape mode, "tap&hold" flips the rotation of the screen upside down, on all launchers(So system related I'm assuming, as my earlier assumptions was it could have been the launcher+fixes).
When in portrait mode, "tap&hold" works perfectly for all launchers!

Bluetooth is confirmed working!
There is no manner or way I can get WiFi working.

The above so far is only for Omni v1.3, with the recent fixes you've supplied.

Test v1.2 - Auto-rotation is also partially working on the ROM, the above rotation error in ROM v1.3 is identical to this version as well. Auto-rotation sensors are working, but it's "tap&hold" is not working on Landscape mode. Portrait mode is fine, just like version 1.3!

WiFi confirmed working,
Bluetooth confirmed working too!

HDMI is confirmed implemented!

Thank you,
Livendead

Avatar
livendead
New Member
Forum Posts: 10
Member Since:
2014/07/11
sp_UserOfflineSmall Offline
71
2014/07/14 - 03:11
sp_Permalink sp_Print sp_EditHistory

pmerrill said

  1. While holding down the Vol+ key on the n80rk, plug a usb cable into the tablet. You should hear the usb bing/bong sound (if you have speakers on your PC of course) and the message on the RKAndroidTool should change to Found.
  1. CWM popup up two screens when you select reboot system now and I just answered No to both of them, though perhaps Yes is a better answer? Maybe someone can provide guidance??

Performance

"I noticed when running OS Monitor (get from AppStore) that rknand_buffer process would start using 5-7% of the CPU and the system would "freeze" for 10-15 seconds"

"As I stated, all works except the camera."

I hope this helps, please feel free to provide feedback and I will update accordingly.

Greetings pmerrill,

For the Aoson M30Q tablet, to boot into the boot-loader, it's 'volume- & power up'. I've also seen quite a few RK3188 chips power up into boot-loader while holding the 'reset' button that is in the pinhole. A good addition to others with clones, or just looking for advice.

As Oma mentioned, when in CWM Recovery, you can safely ignore the warnings, while pressing 'no' to each one.

For the performance, I've had some lock-ups on the stock ROM, I recently acquire the latest update though, released in June 2014, it has exponentially fixed many flaws, including lag with multi-tasking, lock-screen, general improvement with the UI. it uses boot-loader 1.24, and is JellyBean 4.2.2.
I've found that the pre-installed app Entropy Fixer, has provided me with some fixes for lag, lock-ups, crashes - random reboots, shutdowns, etc.

If you got a backup of your original stock firmware, you can test out to see if my stock ROM is a better alternative, if it works, and if the camera works on it too. I am not certain if it will work at all, but I believe it should be fine to try, so long as you always have access to the ROCKCHIP USB LOADER, you can get access back to a ROM with it, for safety. I've got mucked up once, where the boot-loader was corrupt/not working, and it was showing 'ROCKCHIP MASKROM", I used the tool to flash the boot-loader to repair it; When it's stating MASKROM, that's when I use the boot-loader flasher. (Another method I test to see if MASKROM is on, I connect 'RKBatchTool' v1.7, and it shows a blue-box.

I hope you find your ROM working well! I'm interested in how your system is running too, as clones alike!

Regards,
Livendead

Avatar
pmerrill
Active Member
Forum Posts: 23
Member Since:
2013/09/25
sp_UserOfflineSmall Offline

Thanks Received: 2
72
2014/07/14 - 04:10
sp_Permalink sp_Print

Oma7144 said
One of the cores is mainly fully loaded by NAND activity. This is caused by the badly driver for SD/MMC and NAND. RK refused to improve the loader, I guess this has commercial background. So, nothing to do with the kernel or the build itself.

Both answers are NO (instructions advises: do not fix su). Otherwise you will loose su rights.

This tab should have RTL8188 wifi ... can I have a dmesg log to confirm that?

Omni_v1.3_model fix_Vido_N80RK -  http://crewrktablets.arctablet.com/?wpfb_dl=1915

- Oma -

Oma,

I've attached dmesg.log. My tablet appears to have the RTL8188E WiFi from looking at the log. There also seems to be lots of errors

qtaguid: iface_stat: stat_update() lo not found

Avatar
pmerrill
Active Member
Forum Posts: 23
Member Since:
2013/09/25
sp_UserOfflineSmall Offline

Thanks Received: 2
73
2014/07/14 - 04:20
sp_Permalink sp_Print

livendead said

For the performance, I've had some lock-ups on the stock ROM, I recently acquire the latest update though, released in June 2014, it has exponentially fixed many flaws, including lag with multi-tasking, lock-screen, general improvement with the UI. it uses boot-loader 1.24, and is JellyBean 4.2.2.

I'm curious about this update you mention. The Yuandao site has no mention of a new stock for the n80rk. The latest was Sep 2013. The kernel I am using is 3.0.36+ swfour@sw-DESKTOP #45 Tue Sep 10 20:20:37 CST 2013.

Are you suggestion that I can get my hands on a more up to date kernel and flash that to achieve a more stable system?

Avatar
livendead
New Member
Forum Posts: 10
Member Since:
2014/07/11
sp_UserOfflineSmall Offline
74
2014/07/14 - 06:02
sp_Permalink sp_Print sp_EditHistory

pmerrill said

I'm curious about this update you mention. The Yuandao site has no mention of a new stock for the n80rk. The latest was Sep 2013. The kernel I am using is 3.0.36+ swfour@sw-DESKTOP #45 Tue Sep 10 20:20:37 CST 2013.

Are you suggestion that I can get my hands on a more up to date kernel and flash that to achieve a more stable system?

Greetings pmerrill,

I am not certain about an updated stock ROM for your device, I was merely suggesting my recent update.

I'm going to PM you links to your stock anyways just in case!

Regards,
Livendead

Avatar
Oma7144

Moderator

Firmware Guru
Forum Posts: 6315
Member Since:
2012/10/06
sp_UserOfflineSmall Offline

Thanks Received: 1377
75
2014/07/14 - 15:07
sp_Permalink sp_Print

pmerrill said

Oma,

I've attached dmesg.log. 

Hm, isn't there. Could you pls try again?

- Oma -

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online:
75 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (71), Phone (4)

Top Posters:

finless: 604

DarthJabba: 551

maikal: 394

mussonero1: 350

alex: 252

damo: 243

DanielVd: 237

Mark06: 222

Newest Members:

niteaura

radolini

fede32

Ty3uK

pipirska

telo000788

Forum Stats:

Groups: 10

Forums: 185

Topics: 6037

Posts: 60500

 

Member Stats:

Guest Posters: 43

Members: 262194

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix