Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[ ROM ] Arnova 10b G3 Android 4.2.2 custom firmware (Crew RKTablets Loox CM10.1 v1.21) with root and Google Play Store
Avatar
admin

admin
Forum Posts: 5872
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
1
2013/10/09 - 20:08
sp_Permalink sp_Print sp_EditHistory

Here is a test version of a custom Android 4.2.2 Jelly Bean for the Arnova 10b G3 based on Crew RKTablets Loox CM10.1 v1.21   

arnova10bg3_crewrktablets_cm101_v121_cm101.pngImage Enlargerarnova10bg3_crewrktablets_cm101_v121_about.pngImage Enlarger

 

 

This rooted custom firmware features:

  • CyanogenMod 10.1, based on Android 4.2.2 Jelly Bean
  • root with latest SuperSU 1.65 (free version)
  • system default setup to English language
  • Trebuchet Launcher by CyanogenMod Team
  • Google Play Store fixes so more applications are visible/compatible
  • removed all non Google apps, they can later be installed from Google Play Store
  • updated busybox v1.21.0.git (2012-11-29)
  • Unix like init.d boot scripts support, more details on init.d scripts here
  • changed permissions on external sdcard to allow write access
  • storage for applications (/data partition) size increased to 2 GB

 arnova10bg3_crewrktablets_cm101_v121_storage_2gb_apps.pngImage Enlarger

This firmware hasn't yet been fully tested, so far I have noted the following problem:

- camera picture is upside down

- EDIT: DPI probably needs some tweaking

- EDIT: still some issues with charger detection, need to try with services.jar fix.

 

 

Download:  kasty_oma_rk29cm101v121-arn10bg3-422-070-2G.zip

 

Huge thanks to Oma7144, netlars, Astralix, JochenKauz, fr3ts0n (Crew RKTablets) for their amazing work!

The following users say thank you to admin for this useful post:

Sylvania

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
netlars

Firmware Guru
Forum Posts: 149
Member Since:
2013/06/11
sp_UserOfflineSmall Offline

Thanks Received: 29
2
2013/10/09 - 21:14
sp_Permalink sp_Print

I think, the camera problem comes from sensors.rk29board.so.

Let's test us:

 

Load Androsensor from Play-Store and post axis with highest value (9.x) for:

- tab vertical, landscape (y=9.8)

- turn left to portrait (x=9.8)

- turn right to portrait (x=-9.8)

- tab horizontal screen up (z=9.8)

 

 

Avatar
admin

admin
Forum Posts: 5872
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
3
2013/10/09 - 21:45
sp_Permalink sp_Print

Hello netlars,

 

Here are Androsensor values:

- tab vertical, landscape (y=9.8) y=9.9

- turn left to portrait (x=9.8)  x=9.8

- turn right to portrait (x=-9.8) x=-9.6 (this is the highest number, when considering absolute value Wink)

- tab horizontal screen up (z=9.8) z=9.7

 

Cheers.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
netlars

Firmware Guru
Forum Posts: 149
Member Since:
2013/06/11
sp_UserOfflineSmall Offline

Thanks Received: 29
4
2013/10/10 - 10:13
sp_Permalink sp_Print

mmh, values ​​are actually fine.
Let's still a little bit to test.

Download sensors.rk29board.so_XY_Y-X_Z-Z.7z


Avatar
Killyox
Active Member
Forum Posts: 36
Member Since:
2012/07/05
sp_UserOfflineSmall Offline

Thanks Received: 7
5
2013/10/10 - 12:09
sp_Permalink sp_Print

I also have bugs with ADB with this firmware.
I manage to see my device in "adb devices" command, but 20 or 30 secondes later, the adb server "bugs", I have the following error : adb server is out of date.  killing...

Does someone know why I have this error (I also had it with the last cyanogenmod version I try, based on Android 4.2.1) ?

 

Thanks

Avatar
admin

admin
Forum Posts: 5872
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
6
2013/10/10 - 21:25
sp_Permalink sp_Print

netlars, 

I have tested your file from post #4, the camera picture is still upside down Confused

Apart from the camera, the accelerometer works fine and the tablet get proper orientation on all axis, as with your previous test file.

 

Killyox, 

I haven't used ADB a lot but so far it works fine with firmware from post #1, I just had a 5 minutes ADB session on the tablet without problem. I don't know if it interferes, but I switched Settings / Storage to MTP or PTP as I couldn't get ADB working when using USB Mass Storage.

 

Cheers.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
lozweezy
Derry, Northern Ireland
New Member
Forum Posts: 5
Member Since:
2013/05/18
sp_UserOfflineSmall Offline
7
2013/10/14 - 01:43
sp_Permalink sp_Print

Hi everyone, just installed this rom. Great work by the way. Anyhow ive tried the services jar fix

And that hasn't work. But I also noticed the camera was missing from the rom. Is this normal. I kjow from reading the post there has been some issues with it but was just wondering. After I tried the service jar overwrite I rebooted the tablet and now have got stuck at the rk tablets screen. I have an Arnova 10b G3. When I flashed the rom I hit restore instead of update. Could that have caused yhe boot problems? 

Thanks in advance for your help

Dogs

Avatar
Killyox
Active Member
Forum Posts: 36
Member Since:
2012/07/05
sp_UserOfflineSmall Offline

Thanks Received: 7
8
2013/10/14 - 07:15
sp_Permalink sp_Print

Hi lozweezy,

You're right, the base camera app is not installed on this rom (maybe because it's bugged). You can try to install another camera app (like "Focal"), but it seems there's a bug with sensors (see posts upper) and the screen can't roll. Seeing the upper posts, it's not fixed yet (but you can't try netlars fix if you want !).

About the battery bug, I had it on a previous Cyanogenmod version for Arnova 10bg3, and didn't managed to fix it with the services.jar file. I guess it's the same bug on this rom.

Avatar
lozweezy
Derry, Northern Ireland
New Member
Forum Posts: 5
Member Since:
2013/05/18
sp_UserOfflineSmall Offline
9
2013/10/14 - 10:07
sp_Permalink sp_Print

Hi Killyox and thanks for the reply,  Have you ever had the booting problem I mentioned in my previous post? I going to try and reflash using update instead of restore to see if this helps. Any advice? Also the camera I'mnot really cconcerned with. I wouldn't use the tab for yhat anyway.

Thanks again

Lozweezy

Avatar
thechinesekid
New Member
Forum Posts: 1
Member Since:
2013/10/14
sp_UserOfflineSmall Offline
10
2013/10/14 - 23:56
sp_Permalink sp_Print

Thanks for the new firmware, works fine.

 

However I do have a slight problem with certain games automatically closing (I think others have this problem, aka angry birds) <-- not really a big issue

 

What is more of an issue is that my homescreens are larger than my tablet screen (10b G3), I seem to lose about an inch on every side and I'm not sure how to fix this. Could this be the DPI tweaking you mentioned in your opening post?

Avatar
lozweezy
Derry, Northern Ireland
New Member
Forum Posts: 5
Member Since:
2013/05/18
sp_UserOfflineSmall Offline
11
2013/10/15 - 02:31
sp_Permalink sp_Print

Hi guys, right got this ROM all up and working. My problem now is I don't have developed options in settings. Am I missing something? Just want to get adb on the go. Any help would be appreciated.

Avatar
admin

admin
Forum Posts: 5872
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
12
2013/10/15 - 10:13
sp_Permalink sp_Print

You can try that:

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
Killyox
Active Member
Forum Posts: 36
Member Since:
2012/07/05
sp_UserOfflineSmall Offline

Thanks Received: 7
13
2013/10/15 - 10:20
sp_Permalink sp_Print

Thx Admin, it seems putting the USB in MTP mode fixed the issue with ADB. I'll do more tests, but in the last 10 minutes, ADB worked fine.

lozweezy said
Hi Killyox and thanks for the reply,  Have you ever had the booting problem I mentioned in my previous post? I going to try and reflash using update instead of restore to see if this helps. Any advice? Also the camera I'mnot really cconcerned with. I wouldn't use the tab for yhat anyway.

Thanks again

Lozweezy

Hi lozweezy,

I also had the same problem this morning, just after i tried to install the "services.jar" fix given for the OMA firmware. It doesn't work with this file.

I fixed the boot problem by putting back the original services.jar.

If you want me to upload it, I can do it.

The following users say thank you to Killyox for this useful post:

admin
Avatar
admin

admin
Forum Posts: 5872
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
14
2013/10/15 - 10:30
sp_Permalink sp_Print

Thanks for the tip Killyox.

I'll give it a try and if it works fine, I'll rebuild a firmware with that a few other minor fixes.

Cheers.

 

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
lozweezy
Derry, Northern Ireland
New Member
Forum Posts: 5
Member Since:
2013/05/18
sp_UserOfflineSmall Offline
15
2013/10/15 - 11:05
sp_Permalink sp_Print

Hi killyox, thanks again for your help. Has the battery indicator problem been solved? Because mine seems to work. I changed the circle to the standard battery icon and it has shown charging and now its showing full. Also was playing wilh a camera app camera nexus 7 and noticed that when the camera is in panoramic mode the picture on screen is correct. I'm not a dev like most of you guys so I just thought I'd share what I found.

Lozweezy

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online: Gnostyk, jblanco711, kizzar07, Otura
217 Guest(s)

Currently Browsing this Page:
2 Guest(s)


Devices in use: Desktop (194), Phone (25), Tablet (2)

Top Posters:

Oma7144: 5790

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 432

maikal: 394

Newest Members:

Pierre77777

Krikke46

gilesrm

CrunCher

Topgun777

almanori76

Forum Stats:

Groups: 10

Forums: 185

Topics: 5916

Posts: 58878

 

Member Stats:

Guest Posters: 43

Members: 256584

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix