Latest product reviews
ARCHOS 50 Diamond
TV Connect


Please consider registering


— Forum Scope —

— Match —

— Forum Options —

Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
Internal SD Card got lost and no USB drive while connected to PC
New Member
Forum Posts: 7
Member Since:
sp_UserOfflineSmall Offline
2013/04/24 - 13:43
sp_Permalink sp_Print sp_EditHistory

First the Tech Specs of my Arnova GBook:

Manufactor: VIMICRO
Model: ANGB
CPU: ARMv 7 rev 2 (v7l)
Memory: RAM 337, ROM 0.91, SDCard 0 MB (at the Moment more to that later)
Android: 4.0.3
BuildID: generic_vortex-userdebug 4.0.3 IML74K 1.0 test-keys
Linux Version: 3.0.8-vimicro

I copied some files to the mounted exSDCard (4gb noname) when my tablet suddenly died and the only way to reanimate it was by factory resetting it.

After Factory reseting my GBook i got the message that my SDCard was defect and needs to be reformated. I tried that without success. Trying to find out the storage status via Settings -> Storage crashes the settings APP.

A request to Arnova Support to provide me with a ROM image to reflash my reader fell on deaf ears.

The Problem seems to relate to the inability to mount a Nonformated SDCard that i can not format because it is not proberly mounted.

I have no clue how to root the tablet. I tried a set of instruction from a french website, but since i don't speak french i'm not sure if the google translator gave me the right directions.

I tried to mount the SDCard via terminal. Format it connecting the gbook to an ubuntu box and a lot of system tools available via googles play store. USB connection shows the drives but I'm not abel to mount or list the contents of it.

mount is delivering the following:

rootfs on / type rootfs (ro,relatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /mnt/asec type tmpfs (rw,relatime,mode=755,gid=1000)
tmpfs on /mnt/obb type tmpfs (rw,relatime,mode=755,gid=1000)
ubi0_0 on /system type ubifs (ro,noatime,no_chk_data_crc,compr=lzo)
ubi1_0 on /data type ubifs (rw,nosuid,nodev,noatime,bulk_read,no_chk_data_crc ,compr=lzo)
ubi2_0 on /cache type ubifs (rw,nosuid,nodev,noatime,bulk_read,no_chk_data_crc ,compr=lzo)
none on /proc/bus/usb type usbfs (rw,relatime,devmode=666)

The list under /dev/block/vold has three entries:

179:0 179:1 and 7:0

Cat /proc/partitions delivers:

31 0 10240 mtdblock0
31 1 12288 mtdblock1
31 2 120832 mtdblock2
31 3 45056 mtdblock3
31 4 524288 mtdblock4
31 5 1048576 mtdblock5
31 6 262144 mtdblock6
31 7 2169856 mtdblock7
179 0 3909632 mmcblk0
179 1 3905536 mmcblk0p1

using Root Many by Bin4ry to get into my device I got following results:

================================================== ====================
= This script will root your Android phone with adb restore function =
= Script by Bin4ry (thanks to Goroh_kun and tkymgr for the idea) =
= Idea for Tablet S from Fi01_IS01 =
= (20.04.2013) v29 =
================================================== ====================

Device type:
1) Normal
2) Special (for example: Sony Tablet S, Medion Lifetab)
3) New Xperia Root by Goroh_kun (Xperia Z, Xperia V [JellyBean] ...)

x) Unroot

Make a choice: 1
Checking if i should run in Normal Mode or special Sony Mode
Please connect your device with USB-Debugging enabled now
Waiting for device to shop up, if nothing happens please check if Windows ADB-dr
ivers are installed correctly!
remote object '/system/app/Backup-Restore.apk' does not exist
remote object '/system/bin/ric' does not exist
Above file not found warning ARE NOT ERRORS, it is intended to be this way!

Normal Mode enabled!

Pushing busybox....
2207 KB/s (1085140 bytes in 0.480s)
Pushing su binary ....
2185 KB/s (380532 bytes in 0.170s)
Pushing Superuser app
2309 KB/s (1468798 bytes in 0.621s)
Making busybox runable ...
Now unlock your device and confirm the restore operation.
Please look at your device and click RESTORE!
If all is successful i will tell you, if not this shell will run forever.
Running ...
Successful, going to reboot your device in 10 seconds!
Waiting for device to show up again....

After reboot the gbook is throwing "unfortunately UI has stopped" and "unfortunately settings has stopped". Nothing works until i factory reset it again (at least something i am growing really good at) and I'm back to square one.

Other means of editing files within the system via ADB are only leading to access denied or system is in read only mode.

I was also thinking on generating a FW dump according to:

but this won't work because i am not able to push any script or file to my device since it is read only and to root it i need to push files to it too.


In general the System is booting up and i am able to install apps. Since i can't mount any external devices i am not able to transfer files via other means because the gbook wants to copy them to the internal SDCard (wich is not available ).

Any solution i found using Google, Bing and DuckDuckGo seems to require Root Access. Has somebody successfully rooted an Arnova GBook?

Or is there really no possibel solution for a dummy user like me to fix this problem. It seems to boil down that i cannot mount the internal dev to sdcard because "access denied".

Did anybody face a similar problem and fixed it without root?

I am looking for any possible solution. If there is an alternate Frimware i will try it.

Thanks in advance for any offered Help!


Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online: arturas
145 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Devices in use: Desktop (112), Phone (28), Tablet (6)

Top Posters:

Oma7144: 5723

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 430

maikal: 394

Newest Members:







Forum Stats:

Groups: 10

Forums: 185

Topics: 5898

Posts: 58634


Member Stats:

Guest Posters: 43

Members: 255777

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech

CrewRKTablets moderators: JochenKauz and Astralix