Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
USB Host / OTG mode support for external USB Keyboard?
Related Tags
Avatar
paul_c
New Member
Forum Posts: 6
Member Since:
2012/09/24
sp_UserOfflineSmall Offline
1
2012/09/28 - 09:42
sp_Permalink sp_Print

Is it possible to connect an external USB keyboard to this device?

 

Does it require a "USB to go" type adaptor?

 

Currently, I bought a folio case with inbuilt keyboard and it came with two adaptors (one a mini adaptor and the other one a micro adaptor) to convert the standard USB plug that normally goes into the socket on a laptop to fit a micro usb slot, however, when connecting it, nothing happens although the keyboard works fine when plugged into my laptop. I even tried rebooting the tablet with the keyboard connected to see if it needed to see it during boot, but again, nothing happened.

 

I've got an "USB-To-Go" adaptor on order to give it one last chance, but has anyone else had success connecting a USB device such as a pen-drive or keyboard to the 8cG3?

own both Arnova 8c G3 & Arnova 7 G2 tablets plus a Samsung Galaxy S2

Avatar
admin

admin
Forum Posts: 5872
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
2
2012/09/28 - 10:01
sp_Permalink sp_Print

As stated in our Arnova 8c G3 review this device has no USB OTG aka Host Mode support, so the USB port is a slave one that is limited to transferring data to a computer, it shouldn't work with an USB key/keyboard/mouse.

We had a similar discussion for the Arnova 7f G3 that you may want to check.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
Robert.Otto
New Member
Forum Posts: 1
Member Since:
2013/03/01
sp_UserOfflineSmall Offline
3
2013/03/01 - 15:01
sp_Permalink sp_Print

I got working a mouse, keyboard, or Ethernet on the 8c G3. (AN8CG3, Android 4.0.3, Kernel 3.0.8+)

The 8cG3 does not provide power to the USB port, so devices require external power. I used a micro-USB OTG cable that provided a full size USB socket, then a USB Y cable that has one female and two males. One of the males is power only, and I plugged that into a powered hub. Connected the other two plugs to the OTG cable and the device. 

Mouse works.  Keyboard works.

Ethernet works, but appears to support DHCP only (no fixed IP).

I tried one USB hub between the tablet and device, and it did not work. The tablet appears to not recognize the hub. I didn't pursue using a hub any further. Without a working hub, it looks like one can use only one device at a time. It is possible another hub, configuration, or a future OS update could add support. 

 

BTW, The 8 G3 does provide OTG power, but because there is no separate charging connection, I see no way one can charge the tablet while using a mouse, keyboard, etc.

On the 7 G3, USB devices did not work for me even with external power.

 

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online: tokecin, niichikyu2
159 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (135), Phone (22), Tablet (4)

Top Posters:

Oma7144: 5800

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 432

maikal: 394

Newest Members:

Britefon

DSass

niichikyu2

niichikyu

billyboy111

mapo

Forum Stats:

Groups: 10

Forums: 185

Topics: 5919

Posts: 58905

 

Member Stats:

Guest Posters: 43

Members: 256612

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix