Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[HOW TO] Arnova 7h G3 (and most of android tablets) root - 5 minutes of work (or less)
How to root your Arnova 7h G3 (and most others) android tablet
Avatar
LonelyWolf
New Member
Forum Posts: 3
Member Since:
2014/06/26
sp_UserOfflineSmall Offline
1
2014/06/26 - 14:43
sp_Permalink sp_Print sp_EditHistory

Hi all, i'm new here just to share this post (for now!)

Please excuse my poor english, it's not my first language! ;)

My daughter received about 2 years ago this tablet and it was rooted from factory.

About 2 months ago i had to factory reset the tablet trying to solve some problems (most of them caused by installing a lot of crapware!) and yesterday i saw that it wasn't rooted anymore (but google play was already installed and fully working) and it was very slow in everything!

No way to find an original firmware to flash to have back root privileges, but found this forum and i was looking for info.

I've found the topic "Arnova 7 G3 firmware dump (restore your device to stock)" but it's too complicated flashing this piece of hardware.

 

So here we are, i used this method today and the tablet (only rooting it) it's very responsive and fast (mind that it's only an ARM Cortex A8 @ 1 GHz ) i don't know why (maybe some hidden process works better with root access?).

No data lost, no risk to brick your device, for windows and linux.

 

And now that's what you are looking for! :D

I've used this file: Root_with_Restore_by_Bin4ry_v32 (search by google and you will find, the last version is v35 but i didn't tried), done on a pc with windows 7 - 32 bit

1) download and unzip (i'm using the same name as the archive)

2) enable usb debug mode on tablet, connect to your pc and wait drivers are installed (windows version, on linux i don't know)

3) open a command prompt as administrator and navigate to the folder x:Root_with_Restore_by_Bin4ry_v32stuff

4) use command: adb devices, if in the list you can see a long number then skip to 6)

5) install android drivers and repeat from step 4) !

6) go up one folder and run RunMe.bat (.sh for linux users)

7) At first question answer 3 (old method) and follow instructions, there will be to confirm a restore on tablet then an automatic reboot

8) maybe at the end you can see a message like GOTO not defined or something like that, just close the windows, your tablet is rooted, now you can detach it!

PLEASE install SuperSU or another root permission manager, it's for your safety.

 

I am not responsible for any problems that you may encounter, on my tablet everything gone well.

 

I've done this procedure also on some mediacom tablets and it worked.

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online: hotair1983, Otura, WoldoW1
254 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (205), Phone (46), Tablet (6)

Top Posters:

Oma7144: 5784

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 432

maikal: 394

Newest Members:

WoldoW1

WoldoW

twalters81

Vitamindb

paco59

thazel99

Forum Stats:

Groups: 10

Forums: 185

Topics: 5916

Posts: 58855

 

Member Stats:

Guest Posters: 43

Members: 256519

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix