Latest product reviews
ARCHOS 50 Diamond
TV Connect


Please consider registering


— Forum Scope —

— Match —

— Forum Options —

Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
No power, boot, lights after first battery drain. Custom firmware installed.
Related Tags
New Member
Forum Posts: 2
Member Since:
sp_UserOfflineSmall Offline
2012/01/06 - 07:29
sp_Permalink sp_Print sp_EditHistory

I installed the custom firmware (for marketplace access) a couple of weeks ago, shortly after the unit's first use. Everything went fine and it worked great for multiple tests (web, apps, video, etc). It'd been restarted and shut down a handful of times. I sent the gift to my father who also used it no problem via AC and battery until the battery did it's first die. Since then he has no power, boot, lights, etc. Seems dead.


We have no way of reverting back to factory without addressing the problem at hand. Surely it's under warranty (extended service plan via SageMax), but it has the custom firmware on it... Any ideas? Maybe SageMax won't notice the firmware upgrade, not being the manufacturer, addressing the dead unit?


Any help would be great. I thought I might have to dick around with re-flashing/warranty work one day...not a couple weeks after he got it. Figured a new topic was fine as I think this is different than "bricked" after firmware install?


Forum Posts: 11
Member Since:
sp_UserOfflineSmall Offline

Thanks Received: 2
2012/01/10 - 19:04
sp_Permalink sp_Print


Does the charging LED light up when AC power is connected? it could be that the power socket is broken as this happened to mine. Check the socket has a small centre pin present, if not it is damaged and will need to be replaced.

This is a repair you can do yourself if you are handy with a soldering iron. I sourced a suitable socket via Ebay.

Hope this helps.


Forum Posts: 5871
Member Since:
sp_UserOfflineSmall Offline

Thanks Received: 3163
2012/01/11 - 00:09
sp_Permalink sp_Print sp_EditHistory

Soldering a broken power socket is quite easy to do.

Here is the outside picture of the plug I installed on my Arnova 10 (first gen model).

arnova10_connector_soldered_DSC_0087.jpgImage Enlarger


I'll try to find the inside pictures I did when soldering, if it is of any help...

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

New Member
Forum Posts: 2
Member Since:
sp_UserOfflineSmall Offline
2012/01/12 - 04:20
sp_Permalink sp_Print

Hey, guys.


Thanks for the help. I'll keep it all in mind; however, my father's tablet is now operational again from a combination of doing a reset in the pin-hole and/or re-aligning the two-prong North American adapter at the end of the power adapter. He's unsure which one did it, but it is up and running. Potential false alarm. But, again, thanks a lot!



New Member
Forum Posts: 1
Member Since:
sp_UserOfflineSmall Offline
2012/01/13 - 14:54
sp_Permalink sp_Print

Hi All,


I'm a noob to all this Android gadgetry and was a victim lately to a Bricke Arnova 10 g2.Custom upgraded, go launcher ex and not much in internal storage left before the Brick incident!Battery had completely discarged and when plugged in the light was GREEN. I think this means that the machine is not receiving a charge for some reason as when I finally managed to unbrick it the charge is always RED. May be significant, dont really know.

Followed the directions on the other forum page to reset.

I went through a real nightmare trying to reset and after many hours of sticking a drawing pin in the reset hole and sreaming at the PC for not doing a three beep tone I finally got the thing to reset.


Here's how I did it on a windows Vista PC for anyone who's had the same problem:


Downloaded Arnova update file

Downloaded and extracted Batch file and run it, linked in the update file

Power in, usb linked, safety pin for reset at the ready

Hold down the volume up button

Press pin into reset - 5 secs or so ( wait for pc to identify a link)

Take pin out but keep holding volume up, apparently until you hear a three beep tone which indicates the Arnova is in reset mode. This never happened for me and drove me crazy!

On the Batch program clicked update, waited for the % to finish and everytime it was 'Checking upload' it would say that it failed. I tried this soooo many times and it kept happening.

Strangely once it said failed I disconnected the power and usb and pressed power on the Arnova, it powered on briefly for a second then shut off again.

I went through the hole process of reset again (still said failed on Batch) and this time as soon as it switched on I put the power cord in quickly, this for some reason allowed the Arnova to reset and format then count down to a reboot.

It then still did not just switch on! So, then I just hooked up the usb again but did NOT reset. Done an update on the Batch program again and to my amazment it completed for the first time.

I done the same as before, disconnect all cables, switch on Arnova, plug in power, wait very very patiently for the machine to reset and reboot and then finally come to life. It stayed on boot screen for a little while and then was back to working condition.


I believe there to be a fault with the battery as I had no problem with it or the firmware custom update until the battery had completely depleted. So, i'm going to make sure i dont run the battery down again.

Hope this will help at least one unfortunate soul in the same situation.

Oh, one more thing, the custom firmware is really good and I don't feel that it had much to do with the Bricking, i dont know too much on the technical side but it does seem more towards a battery problem on the Arnova.

Kingston upon hull, UK

Forum Posts: 243
Member Since:
sp_UserOfflineSmall Offline
2012/01/13 - 15:13
sp_Permalink sp_Print

Well Done Smile


With regards to battery please read through do and dont on this link



Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online: PrEzi, Kon Diter
190 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Devices in use: Desktop (169), Phone (20), Tablet (3)

Top Posters:

Oma7144: 5723

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 430

maikal: 394

Newest Members:

Kon Diter





Forum Stats:

Groups: 10

Forums: 185

Topics: 5899

Posts: 58644


Member Stats:

Guest Posters: 43

Members: 255833

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech

CrewRKTablets moderators: JochenKauz and Astralix