Forum switched to read-only as of 2020/06/01


Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
Arnova 10 G2 Bricked After Firmware Upgrade (different screen)
Related Tags
Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
16
2011/12/12 - 02:58
sp_Permalink sp_Print

When in XP mode there is a menu at the top window.  This is how you attach USB devices to XP mode.  You have to do that once you get into recovery mode.  Then and only thwen can you install the RK29 drivers.  So try this.

1) Have XP mode up and running.  Have the tablet plugged into USB.

2) Put the unit into recovery mode as described here.  e.g. pin in the reset hole WHILE also pushing the up volume button.  Hold both for about 5 seconds then relese the pin hole and continue to hold up volume.  Keep holding up volume until you here your main Windows (not XP Mode) dong and then dong again in the rapid succession.  You should have a black screen on the G2.

3) Now go into XP mode screen and attach the UNKNOWN usb device. FYI, It will always list as it as a unknown USB device even after you get the drivers installed in XP mode.

4) Now go to device manager in XP mode and do the manual install drivers.  You DO have the correct RK29 drivers yes?  Make sure you have put those on your VM drive in XP mode.  DO NOT try to install them with XP Mode's "enable integration" from a drive.  Enable Integration and copy them to your XP Mode hard disk then disable intgration features.

 

If in XP mode it does not show up as a "unknown" USB device but instead shows up as a Arnova G2, you are not in recovery mode.

 

If you have no luck, I will try to do a video for you tomorrow or something.

 

Bob

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
17
2011/12/12 - 03:01
sp_Permalink sp_Print

Hey I am willing to do this for you.  If you just cant get it....  PM me and we can work out you shipping it to me and I will fix it for you no problem.  You pay shipping to me and back and all done.

 

FYI not sure anyone here knows who I am but I am very trusted person on a RC Heli web site called http://www.helifreak.com.  Look up finless there and you will see I do this kind of stuff all the time.

 

Bob

Avatar
munzab
New Member
Forum Posts: 10
Member Since:
2011/12/11
sp_UserOfflineSmall Offline
18
2011/12/12 - 08:53
sp_Permalink sp_Print

bob, many many thanks for that. i still havent managed to do it properly unfortunately. id be really happy if you could post a video all right.

 

is there any chance you could post the drivers?i am using the ones in the rockchip tools 1.4, so i dont know whether they are correct or not. i tried others i found on the net, but no dice either.

 

i still cant seem to get it into recovery mode, so a video is going to be very helpful i think.

 

thanks again for your patience, its very very very appreciated.

 

i gather you are in the US? i am in Ireland, i think postage in total is going to be more than what the tablet is worth!

Avatar
admin

admin
Forum Posts: 5878
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3172
19
2011/12/12 - 10:38
sp_Permalink sp_Print

I have been very busy to finish the Rockchip RK29xx flash tool tutorial, I hope get the procedure online by the end of the day, with a video to follow soon.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.


Avatar
munzab
New Member
Forum Posts: 10
Member Since:
2011/12/11
sp_UserOfflineSmall Offline
20
2011/12/12 - 15:27
sp_Permalink sp_Print

thank you very much, ill wait for that eagerly.

Avatar
admin

admin
Forum Posts: 5878
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3172
21
2011/12/12 - 21:59
sp_Permalink sp_Print

The flashing procedure has been published: /blog/featured/flashing-arnova-g2-rockchip-2918-rockchip-flashing-tool/

 

The tutorial Video should follow tomorrow.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
munzab
New Member
Forum Posts: 10
Member Since:
2011/12/11
sp_UserOfflineSmall Offline
22
2011/12/12 - 23:58
sp_Permalink sp_Print

thanks for that. unfortunately, because i have no idea with the screen already being black, i dont know when its turned off or not.

 

basically, whenever i connect a usb cable, it turns on. am i correct in that even if its in BRICK mode, i press power button and keep pressing, and that should turn the tablet off? the usb and power button are still connected. however, the tablet turns on by itself i think or never turns off.

 

if i press the reset pinhole thing, the usb noise i get is one that you get when disconnecting a usb device.

 

god this is hard.

 

thanks for the tutorial though. i guess ill wait for the video just to make sure, but its not looking too good.

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
23
2011/12/13 - 01:11
sp_Permalink sp_Print sp_EditHistory

OK yes that is the issue with the Arnova being bricked.  I have now played with this a bit.  Even bricked it will power on when you plug in power cord OR the USB port.  So realize this!

However the reset button still does it's thing either way! 

Put the USB cord on it and make sure power is hooked up as well.  Don't worry if windows freaks out about drivers just yet!  Close all that stuff in windows and do not install drivers.  Close and get rid of ANY driver dialogs.

OK now the important part.  The reset button.  Do not worry what the heck the condition of the tablet is in.  Hold down the volume up button.  While holding that now put a paper clip in the reset hole and push down.  HOLD the reset hole for at least 5 seconds.  Now let off the reset hole while holding the volume up.  Again as I said above you may get a DONG from widows for a device but keep holding volume up!  After 15 seconds or so you should get more windows device dongs.  Now you can release the volume up. 

 

In the device manager in windows you should now have a "unknown" usb device.  Right click on it and do a driver update.  Follow the excellent instructions admin has posted to install the driver.

 

The uploader app will show a green box if you have done this properly.

 

Bob

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
24
2011/12/13 - 02:24
sp_Permalink sp_Print sp_EditHistory

Interesting…. VERY interesting…..

 

So now I have a XP Mode VM that no matter what I do will now not work.  I used it several times to reflash but now the device is recognized by windows but the Batchtool will not see the device connected.  I get NO green box.  The driver is installed and shows in the device manager tab when I do the recovery mode thing but alas, batch tool will still not see it as connected.  I left the G2 in recovery mode and plugged it into my laptop and no issues. Batchtool saw the device.  So for sure I have the G2 in the right mode.  Yet my VM will now no longer talk to it 🙁

 

It appears the XP drivers may not be all that robust.  I even tried uninstalling which HUNG the VM and reinstalling but no go.  I am going to bring up a brand spanking new XP Mode VM and try again to make sure Win 7 64 is not doing something to it. Stay tuned.

 

Bottom line I feel there is some stability issues with the driver.  If that is the case I will tell folks how to manually remove the driver so you can start from scratch if needed.  Something for sure is screwy.  All my years of using TEST environments in XP mode or other VMs I have never seen this happen to a driver.

 

Bob

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
25
2011/12/13 - 03:31
sp_Permalink sp_Print sp_EditHistory

OK so now I cannot use a XP Mode VM anymore.  Not sure what happened but it will not work.

All the tools and other things I have installed on this machine must be causing a problem even for a VM.  It works in Oracles Virtual Box but not in MS XP mode now.  I bet I installed a 64 driver somewhere along the route of me learning to hack Andriod OS.  Bummer.  Only thing I can do is reinstall to find out why and I am not going to do that.

 

FYI a XP Mode installed with Win7 32 works.  Go figure.  My laptop on Win7 32 also works no issues.  XP mode VM… no worky now and what bums me aout about that is I used it for at least a week now to reflash.  If I ever figure it out I will let you Win7 64 bit guys know what was the issue but until then….. Consider XP Mode under Win 64 a no go.  Well at least un reliable which is important when recovering from a brick install!

 

Tonight I am actually going to spend the time to bring up a dual boot XP SP3 and see how well all this works on a fresh XP install.  I know it works fine on a fresh install of win7 32 but I question it on XP SP3.  We shall see.

 

Bob

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
26
2011/12/13 - 07:47
sp_Permalink sp_Print

FYI, my clean install of a dual boot of XP works.  So it's not any odd machine (PC) issue. So my XP Mode VM stopped working because of something I did in Win7 64 and I seriously can't figure out why.  I am not going to waste my time anymore trying.  It pisses me off but thats Winbl0ws 😉

FYI Virtual Box works no problem!  Use that if your a win7 64 bit users and need a way to flash until Rockchip comes out with Win7 64 bit drivers for the RK29.

Munzab, I really hope you got it all figured out now?  Let us know please.

 

Bob

Avatar
munzab
New Member
Forum Posts: 10
Member Since:
2011/12/11
sp_UserOfflineSmall Offline
27
2011/12/13 - 12:31
sp_Permalink sp_Print sp_EditHistory

i do appreciate all the help i am getting, definitely. but this is really puzzling me now.

 

basically ive uninstalled the bogey driver in device manager. whenever i connect the usb to the computer, this is the message i get:

 

"USB device not recognised a device attached has malfunctioned".

 

now, this appears when i first connect it and when i press the vol up + reset hole. When i let go of the reset hole, the device disappears from device manager (as the device turns off i think). i keep hold of the vol up button and after 15-20 seconds, the usb device not recognised comes up again.

 

i dont think its not being in recovery mode. ive done it so many times that i am sure i must have entered recovery mode at some point. its just windows and drivers thing that is driving me nuts.

 

i am on a laptop, i dont think its the usb on the laptop thats the problem (i managed to restore and update an iphone and ipad fine yesterday so i could sell them, in between all those problems with the arnova).

 

ive attached an image of the device manager and the usb not recognised message.

 

thanks again for taking the time to think this through and trying to help.

 

arnova have not responded to me, its been 2 days now, so thats another avenue that will take time. from my dealings with some companies, im not very hopeful of getting proper help there.

 

http://img23.imageshack.us/img23/2865/unknowndevicejpegx.jpgImage Enlarger

<img src="/blog/forum/arnova-10-g2/arnova-10-g2-bricked-after-firmware-upgrade-different-screen/[Image Can Not Be Found]%20%20Uploaded%20with%20ImageShack.us" alt="" />

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
28
2011/12/13 - 18:51
sp_Permalink sp_Print

In my post I said to ignore those driver messages.  After the 15 seconds you get that message.  Don't worry about it.  Open device manager and look for the unknown USB device in the list.  Right click on it and do a update driver.  Do the manual choice and point the dialog at the driver/win7 folder.  Do not open the win7 folder just select it.  The driver install OK buttom should become available when you point it at the win7 folder.

 

Bob

Avatar
munzab
New Member
Forum Posts: 10
Member Since:
2011/12/11
sp_UserOfflineSmall Offline
29
2011/12/13 - 18:55
sp_Permalink sp_Print

bob, im not being funny, i did do that, and when i manually select the folder, it searches and says windows' driver is up to date, and remains unknown device... 🙁

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
30
2011/12/13 - 22:27
sp_Permalink sp_Print

Try this then.  Go into the device manager while it is plugged in.  Right click on the unknown device and see if you can do a uninstall.  If that does not work I will need to go find the driver ini file and tell you how to manually delete it.  You have something messed up with another driver or something.

 

Bob

Forum Timezone: Europe/Paris

Most Users Ever Online: 803

Currently Online:
74 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (66), Phone (8)

Top Posters:

finless: 604

DarthJabba: 551

maikal: 394

mussonero1: 350

alex: 252

damo: 243

DanielVd: 237

Mark06: 222

Newest Members:

ibiky

cutierogue

edds1

andreive

hans41

rickybk

Forum Stats:

Groups: 10

Forums: 185

Topics: 6037

Posts: 60500

 

Member Stats:

Guest Posters: 43

Members: 262194

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix