Forum switched to read-only as of 2020/06/01


Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[ ROM ] Arnova 10 G2 improved custom firmware update (full root, increased app storage space) by Finless
sp_BlogLinkWhite Read the original blog post
Tags: bob
Related Tags This topic is locked
Avatar
tanktech87
Active Member
Forum Posts: 21
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
121
2011/12/27 - 03:57
sp_Permalink sp_Print

Yes it must have been the old rom i had on before haha oh well. On the last rooted firmware i had the android market from arctools showed every app ever made i think. It was the same market as my xperia play and worked perfectly. This one shows about 5 apps in each category.

 

Could it be that I used the drivers from the arnova10G2_full_root_ROM folder? the 1.0 version and not the 1.1 folder or does that not make a difference?

 

I'm a noob at this but i think im learning a lot.

cant sleep  .....

Avatar
giga8547
New Member
Forum Posts: 2
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
122
2011/12/27 - 05:57
sp_Permalink sp_Print

finless said

giga8547, if you read some of the posts lately about appslib, they have been having some problems the last few days. Same complaints from many for at least 3 days now.  This issues with it have nothing to do with the ROM. 
My wife played Angry birds all day yesterday on my 10G2 with no hangs or issues, so you might be right about the hardware if you're having trouble or maybe some other app is causing a problem?  I had a live wallpaper installed early on that would cause all kinds of instability on the stock rom.finless said

For Market login problems, do these steps and it usually solves it.  I have had it happen a few times myself and it does matter which version of Market I installed.

1) Go into manage apps, select all apps (not just downloaded), and find; Google Services Framework.  Click on that and click on the clear data button.

2) No go back and find Gmail if you have it installed.  Go into that and clear data as well.

3) DON'T DO ANYTHING at this point!  Power off completely and power back on.

When you come back up go right to the market and try to logon using your existing account.  It should work.  This procedure has always cleared up the first login issues I have had when first installing the Market.

 

giga8547, if you read some of the posts lately about appslib, they have been having some problems the last few days. Same complaints from many for at least 3 days now.  This issues with it have nothing to do with the ROM. 
My wife played Angry birds all day yesterday on my 10G2 with no hangs or issues, so you might be right about the hardware if you're having trouble or maybe some other app is causing a problem?  I had a live wallpaper installed early on that would cause all kinds of instability on the stock rom.

 

Jonni, your screen looks just like the issue of not clicking the EraseIDB before flashing.  Erase IDB erases the Image Definition Block.  This HAS to be done since we are changing the size of the image block for the new firmware.  e.g. we are making more space for apps, etc.  If you do not erase the IMGs get installed wrong and you get a garbage screen like yours is showing.  So try again and eraseIDB and flash with my firmware.  If you want to go back to stock then use these instructions here for doing that.  You cannot use my tools to flash stock firmware since you do not have the stock firmware in IMGs.  You only have update.img.  So follow these instructions here:

/blog/featured/flashing-arnova-g2-rockchip-2918-rockchip-flashing-tool/

 

Bob

hey bob i did do some more reading on applib after i posted but i did not think aplib server issue would issue a error on the arnova saying the system did not have any free space to install the app or download the app and from my understanding the app actualy downloads stuff from applib to the system folder to a chach first then moves it to the data section in the nand to free up system space. but i am not 100% sure about that but alot of the app stores i have seen dose that likt the cruz market on the cruz reader and all cruz products with android dose the temp hold in system before moving to data or sd card depending on the setup.

any way i have started taking apart the news edition to look at its hardware and chip sets i found the news eddition uses a newer wifi card but only dose a/b/g where the retail is suposed to do a/b/g/n unless i read that wrong so there is some difference right out of the box will keep you posted on this

now the nand which is read as an sd device under system and used as sd if you do not have a micro sd installed (if you do have micro sd installed it shares and shaddows the nand onto the microsd weird but it works) so my question is is it not possible to partition the nand in such a way to divert say 600mb or more to the data and system areas or would that be a little more difficult and i realy havent looked at the chips that well yet but there is only one nand or storage flash chip on the entire board and it is like 4gb or something with 1gb originaly reserved for sytem, boot, cach,ect and the reaminder is for the onboard simulated sd card.

Avatar
MIDURIX
New Member
Forum Posts: 3
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
123
2011/12/27 - 14:00
sp_Permalink sp_Print

Works great on my uk 10 g2. Just wish that some of the gameloft games would work with this tablet, anyone else having the same problem?

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
124
2011/12/27 - 16:02
sp_Permalink sp_Print sp_EditHistory

giga8547, /system on the stock ROM is not writable.  Stock it uses a cramfs file system which is read only so basically nothing writes to /system.  This was part of my root.  I converted /system from cramfs to ext3.  This made it writeable.  Then of course I had to set all the permissions as rw, etc to complete the root.  Any of the other directories in /system that were writable were symbolic links to an area in NAND.  So no, no apps were writing to /system as it was impossible.  I also did not change any of the original symbolic links to NAND so those work the same.

However that said, for some of the rooted apps that need to write to /system like arctools, titanium backup, etc I could give /system more space.  Right now it has 10mb free from my rooted ROM and after installing the Market rooted, arctools, and titanium backup I have 4mb left free in system.  So it probably could use some extra space.  But this is not is what is causing appslib to not work. Go back to the stock ROM and you will see appslib still give you that error as well as other errors.  I get "cannot connect" or the app freezes and I have to kill it.  I do not know why.  Everyone even people with other tabs non-rooted are complaining of this.

In fact the Admin made this a blog topic 4 days ago:

/blog/featured/appslib-fails-download-unsuccessful-make-sure-you-have-free-space/

 

Bob


Avatar
tanktech87
Active Member
Forum Posts: 21
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
125
2011/12/27 - 16:14
sp_Permalink sp_Print

@MIDURIX hey man im in the uk but im having trouble with my market. Did you install the rooted 3.4.4 package from arctools 0.57? let me know dude

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
126
2011/12/27 - 16:39
sp_Permalink sp_Print

giga8547, OK just to make sure I flashed back to stock ROM.  Appslib still does not work.  I get either a connection error, crashes, or other errors.  One time it did give me the EULA and I was able to accept but when the list of apps came up and I clicked one it crashed.  Also their web page says under maintanance:

http://appslib.com/

OK so now to flash back and see if titanium backup really does restore all my stuff.  Never tried a restore before so we shall see.

Bob

Avatar
Jakeup96
Member
Forum Posts: 16
Member Since:
2011/11/27
sp_UserOfflineSmall Offline
127
2011/12/27 - 16:50
sp_Permalink sp_Print

Titanium works great, I was even able to restore things I'd backed up on my phone. 

 

I know when I first installed this firmware I got the "Can't establish reliable data connection" or what ever that error message is when trying to sign in to the market. I didn't Erase NAND, but did do a Factory Reset under Privacy and then once it booted back up reinstalled the market usingthe rooted option on Arctools .57 which was exactly how I did it the first time but it worked the second time.

 

It sucks that so many people are having problems(which honestly it has to be user error) because this really is a great rooted firmware.

Avatar
MIDURIX
New Member
Forum Posts: 3
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
128
2011/12/27 - 18:11
sp_Permalink sp_Print

tanktech87 said

@MIDURIX hey man im in the uk but im having trouble with my market. Did you install the rooted 3.4.4 package from arctools 0.57? let me know dude

I used 0.6 I think.

 

This one:

 

http://www.arctablet.com/blog/wp-content/uploads/2010/12/com.arctablet.arctools.apk

 

I didn't select anything, it just installed the old market, then the tablet must have auto updated to the newest by itself. I love my 10 G2 now, stock rom almost made me kill someone on Christmas day, which isn't very festive. Only problem is that for me it won't work with the better 3D/HD games from Gameloft, although I think if you try different versions of the apk's it might work out

Avatar
nwhite89
Active Member
Forum Posts: 21
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
129
2011/12/27 - 18:25
sp_Permalink sp_Print

Hi I am new to all of this (got the G2 for X-Mas) 

 

I have installed the 1.1 custom ROM and using Arctool 0.57 downloaded and installed "Default Apps & Market 3.4.4 (root Install)" 

 

It claims its all done without an issue however no further apps have installed? 

 

Am I missing something? Any help with this would be really grateful

Avatar
tanktech87
Active Member
Forum Posts: 21
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
130
2011/12/27 - 18:29
sp_Permalink sp_Print

@nwhite89

 

after you installed the apps from arctools, did you reboot your device straight away? 

 

tanktech87

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
131
2011/12/27 - 18:30
sp_Permalink sp_Print sp_EditHistory

Did you reboot like it said to?  You must reboot.

Then on next boot up it does not put an icon on your default screen.  There is a menu bar on the far right side.  Touch the icon that looks like a bunch of little boxes.  This will take you to your APP Drawer.  In there should be one new icon called Market.

If you want the Market icon on your default screen (home screen) touch your finger on the home screen for a few seconds.  You will get a pop up menu.  Add application and then select the Market app and it will add that icon to your default home screen.

 

Bob

Avatar
nwhite89
Active Member
Forum Posts: 21
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
132
2011/12/27 - 19:10
sp_Permalink sp_Print

Ok Market is now in there however next to no apps are listed I even searched Facebook and that couldn't be found?

 

Sorry to waste your time

Avatar
tanktech87
Active Member
Forum Posts: 21
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
133
2011/12/27 - 19:16
sp_Permalink sp_Print

@nwhite89

 

im having the same problem as you. MIDURIX says he installed arctools 0.60 and it worked for him. I'm going to try that later. I dont think it matters but like me are you from the UK?

Avatar
rakana
New Member
Forum Posts: 9
Member Since:
2011/12/21
sp_UserOfflineSmall Offline
134
2011/12/27 - 19:16
sp_Permalink sp_Print

hi Bob. plz help me

i tried to install the firmware, u told that in the text

4) While holding the UP volume button stick a pin in the reset hole and hold both volume up and reset
5) After about 5 seconds you will hear your PC dong that it found hardware.
RELEASE the reset button but keep holding volume up.
6) While holding volume up you should again hear your PC dong that it found new hardware.
It's OK to release the volume up now. The screen should be black at this point.

 

so now I tried the point num 4 but I couldnt coz I hold but the tablet didnt reset

 

also u told    

6) Open the device manager in control panel. You should see a device listed as unknown with a yellow symbol in it
RIGHT click on it and select "Update Driver".

 

but my laptop see the tablet as a driver in the my computer but it doesnt see it in device manager, so I dont wheres the problem

 

sorry if noised u with me, thanks alot

Avatar
nwhite89
Active Member
Forum Posts: 21
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
135
2011/12/27 - 19:19
sp_Permalink sp_Print

tanktech87 said

@nwhite89

 

im having the same problem as you. MIDURIX says he installed arctools 0.60 and it worked for him. I'm going to try that later. I dont think it matters but like me are you from the UK?

 

I am from the UK yes I did it with ARC Tools 0.60 first of all actually and got it working however Apps wouldn't download it would throw an error so I tried 0.57 way

This topic is locked
Forum Timezone: Europe/Paris

Most Users Ever Online: 803

Currently Online:
50 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (48), Phone (2)

Top Posters:

finless: 604

DarthJabba: 551

maikal: 394

mussonero1: 350

alex: 252

damo: 243

DanielVd: 237

Mark06: 222

Newest Members:

igijabet

jacksonrid

usdown

ibob64

kawi

vetBro

Forum Stats:

Groups: 10

Forums: 185

Topics: 6037

Posts: 60500

 

Member Stats:

Guest Posters: 43

Members: 262194

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix