Forum switched to read-only as of 2020/06/01


Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[ ROM ] Arnova 10 G2 improved custom firmware update (full root, increased app storage space) by Finless
sp_BlogLinkWhite Read the original blog post
Tags: bob
Related Tags This topic is locked
Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
16
2011/12/22 - 21:42
sp_Permalink sp_Print

Wow guys I found one of the major reason that /system was RW but some things would not work.

For any of you guys doing this on your own. DO NOT take files created by or touched by Windows.  Wendals tools when they unpack make some files in /system with ownership of user 400 not root!  His tool .lua script does chmod but does not use chown to switch all files to ownership root.  

Then if you work on a file and open it in windows even if you do not edit it, the ownership is changed to user 400.

Freakin Windows!  Now I am doing everything in Ubuntu and things are working.

 

So my mistake folks.  Hey... I am learning here so please forgive.  I will have a new version 1.1 rom today.

 

Bob

Avatar
p1ceus

Contributor
Forum Posts: 38
Member Since:
2011/11/23
sp_UserOfflineSmall Offline

Thanks Received: 1
17
2011/12/22 - 21:51
sp_Permalink sp_Print

No problem man, take your time 🙂

Avatar
Dayveee
New Member
Forum Posts: 4
Member Since:
2011/12/15
sp_UserOfflineSmall Offline
18
2011/12/22 - 22:49
sp_Permalink sp_Print

This is all great with 10 G2! Now, does anyone want to get started on a Gingerbread/ICS port. For I would truely love that. :3 

Avatar
Dayveee
New Member
Forum Posts: 4
Member Since:
2011/12/15
sp_UserOfflineSmall Offline
19
2011/12/22 - 22:57
sp_Permalink sp_Print

Honeycomb I mean. 
You have permission to slap me silly. 


Avatar
rouge1

Contributor
Forum Posts: 28
Member Since:
2011/12/15
sp_UserOfflineSmall Offline
20
2011/12/22 - 23:28
sp_Permalink sp_Print sp_EditHistory

finless said

Wow guys I found one of the major reason that /system was RW but some things would not work.

For any of you guys doing this on your own. DO NOT take files created by or touched by Windows.  Wendals tools when they unpack make some files in /system with ownership of user 400 not root!  His tool .lua script does chmod but does not use chown to switch all files to ownership root.  

Then if you work on a file and open it in windows even if you do not edit it, the ownership is changed to user 400.

Freakin Windows!  Now I am doing everything in Ubuntu and things are working.

I was able to fix the permissions by mounting the system.img and “chown –R –h root:root *” and Refash.  Rooted apps are working fine with this.

As for arctools. This is not working.

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
21
2011/12/23 - 00:11
sp_Permalink sp_Print sp_EditHistory

Arctools requires some symbolic links to be made to /system to work.  I have done that and it is working now.

rouge1, yes this is what I did to /system in Ubuntu and then saved the new system.ing which solved ALL the problems.  Freakin WINDBLOWS!  I love it for some things but this kind of stuff requires Linux that doesnt change stuff on you (like ownership) when you don't want it to. Thats what I get for using it to pack and unpack or edit files 🙁

 

I am almost done with the new rom that will support Arctools.  I am going to leave appslib in for the new people as they need some kind of market to start out with!

Anyway sorry guys for the trouble.... Really...  I should have tested more myself.... Can't thank you all enough for testing and letting me know the issues.

Bob

Avatar
RavenBrother
New Member
Forum Posts: 2
Member Since:
2011/12/22
sp_UserOfflineSmall Offline
22
2011/12/23 - 00:14
sp_Permalink sp_Print

Hi,  Thanks for yourCool hard work.  It is us who can not do what you do that need to thank you Finless.

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
23
2011/12/23 - 01:05
sp_Permalink sp_Print

I am uploading to my server now.  Stay tuned.  In about 20 minutes I will update this post with FW version 1.1.

AGAIN... you guys are testing for me even though I have tested everything people posted here that did not work.  It all works now including Arctools, EF file manager, Titanium backup, etc.

 

Be right back with my link.  I hope the admin is around to update his blog post with my new version as I am worried my server will get hammered until he gets it posted here.

 

Bob

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
24
2011/12/23 - 01:29
sp_Permalink sp_Print sp_EditHistory

OK.... again sorry all for making you guys BETA testers!  Crap happens 😉

I am pretty sure I got this all fixed now.  Here is what is new:

1) This should be full root this time!  Damn it ticked me off I made those ownership mistakes in the first ROM!  Call me a n00b it's OK 😉  I can take it cause I am!

2) Appslibs comes installed with the ROM.  New people need this at a minimum so I left it in this time.

3) Arctools works!  Get version 0.57 from appslib.  When it runs use install market 3.4.4 (root Install). The rootless install does not work for me.  But root install does with no issues.

4) The boot screen now says version 1.1 so you know you got the right version.  If when you reboot it does not say that, your on the old 1.0 version!  FYI, my original had no version number on it. Now they will always.

5) Nothing else has changed that I am aware of!

I will work on a update.img version but I have to tell you NO ONE has successfuly done that yet that I am aware of including the for T760, Wopad, or Nextbook.  They all require use of RKAndroid flash tool 1.29.  This is because the boot.img for RK29 is different and has a header and footer.  We can recreate the header but not the footer at this time.  The AFPTool requires the footer to make a proper update.img.  So sorry but until I can crack this issues, no update.img 🙁

 

Here is the link: http://www.helifreakswag.com/arn10g2-23-1_1.zip

 

Admin please host this as soon as you can as I fear my server will barf if it gets hammered.

 

Thanks all....
Bob

Avatar
rouge1

Contributor
Forum Posts: 28
Member Since:
2011/12/15
sp_UserOfflineSmall Offline
25
2011/12/23 - 02:11
sp_Permalink sp_Print

finless said

3) Arctools works!  Get version 0.57 from appslib.  When it runs use install market 3.4.4 (root Install). The rootless install does not work for me.  But root install does with no issues.

Market (root Install) in arctools is not working. the normal Market 3.4.4 version is working.

the rest seems to be working fine.

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
26
2011/12/23 - 02:16
sp_Permalink sp_Print sp_EditHistory

rouge1 said

finless said

3) Arctools works!  Get version 0.57 from appslib.  When it runs use install market 3.4.4 (root Install). The rootless install does not work for me.  But root install does with no issues.

Market (root Install) in arctools is not working. the normal Market 3.4.4 version is working.

the rest seems to be working fine.

 

I used Arctools 0.57 and installed 3.4.4 (rooted) and it worked fine for me.  You have to reboot as it says.  I tested this at least 3 times myself from a fresh flash!  Please can you state the steps you used and when it did not work please.  This bothers me as again I tested at least 3 fresh flashes 🙂

 

Question... Did you EraseIDB before you flashed?  This is important!

 

Bob

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
27
2011/12/23 - 02:27
sp_Permalink sp_Print

FYI I used on the 4 choices in Arctools the bottom choice; "Default apps & Market 3.4.4 (root install).   I did not test anything else other than "Default apps & Market 3.4.4 (rootles install), which did not work for me.  Remember Admin is BETA testing rootless install now so please use the (root install). 

 

Bob

Avatar
rouge1

Contributor
Forum Posts: 28
Member Since:
2011/12/15
sp_UserOfflineSmall Offline
28
2011/12/23 - 02:31
sp_Permalink sp_Print

I did EraseIDB.

Arctools .57 is no longer in appslib, only .58

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
29
2011/12/23 - 02:35
sp_Permalink sp_Print sp_EditHistory

OK I just did a ERASE NAND then followed by a >privacy>factory reset. The system rebooted.

Then I installed Arctools 0.57

Then I ran Arctools and selected; Default apps & Market 3.4.4 (root install)

I downloaded the package using the Arctools download button

I clicked "install" using the arctools install button

I cold rebooted the Arnova e.g. turned it off and back on.

It booted back up and the Market app was in my applications list. 

I ran it and logged in.

Everything worked.

 

Please let me know what did not work for you with arctools as I cannot recreate a failure using the above.

Bob

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
30
2011/12/23 - 02:37
sp_Permalink sp_Print

CRAP..... OK let me download Arctools 0.58.  Sheesh... I hope thats not it 🙁

 

Bob

This topic is locked
Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online:
89 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (75), Phone (13), Tablet (1)

Top Posters:

finless: 604

DarthJabba: 551

maikal: 394

mussonero1: 350

alex: 252

damo: 243

DanielVd: 237

Mark06: 222

Newest Members:

swan12

fansosagelos

Snowm

andrewbest

heftpflaster

ruta6

Forum Stats:

Groups: 10

Forums: 185

Topics: 6037

Posts: 60500

 

Member Stats:

Guest Posters: 43

Members: 262194

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix