Forum switched to read-only as of 2020/06/01


Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[ ROM ] Arnova 10 G2 improved custom firmware update (full root, increased app storage space) by Finless
sp_BlogLinkWhite Read the original blog post
Tags: bob
Related Tags This topic is locked
Avatar
mozart321
Member
Forum Posts: 13
Member Since:
2011/12/28
sp_UserOfflineSmall Offline
181
2011/12/28 - 18:12
sp_Permalink sp_Print

Hi Thanks for all the work, I installed and everything works except:

I cannot use arctools (0.57 or 0.60) to install the Google apps.  It keeps giving me error 25, file copy failed, archive cannot be accessesed make sure your device is not mounted on USB.

 

It isn't mounted on USB.  I have reinstalled the custom firmware about 4 times - but still can't sort it out.

Can anybody help please?

Thanks.

Avatar
kaymado
New Member
Forum Posts: 4
Member Since:
2011/12/23
sp_UserOfflineSmall Offline
182
2011/12/28 - 18:40
sp_Permalink sp_Print

mozart321 said

Hi Thanks for all the work, I installed and everything works except:

I cannot use arctools (0.57 or 0.60) to install the Google apps.  It keeps giving me error 25, file copy failed, archive cannot be accessesed make sure your device is not mounted on USB.

 

It isn't mounted on USB.  I have reinstalled the custom firmware about 4 times - but still can't sort it out.

Can anybody help please?

Thanks.

 

hi pal,

 

to me it seems like you are trying to access the file from a location that does not exist (which can be caused by plugging in a usb flash drive for example).

 

One thing that is not yet resolved (for me at least), is the mounting. Whenever i plug in a hard drive or usb stick to the arnova, the programs moved to SD card, will not work. And my only fix so far is to restart the device. It all then works fine.

 

So... i guess that this is something related to it as the internal storage kind of disappears....

simply copy the arctools anywhere to built in memory and after ejecting the usb drive/stick (unplugg everything if you have to!), restart and then i believe you will be able to install arctools

 

remember than once you run the "root install google apps" they will only show once you restart the device.

Avatar
superman
New Member
Forum Posts: 6
Member Since:
2011/12/28
sp_UserOfflineSmall Offline
183
2011/12/28 - 18:45
sp_Permalink sp_Print

Thanks for all the help guys were can i get the rkandroidtool from,and also is there a way to get the android market without rooting the archos thanks alot

Avatar
mozart321
Member
Forum Posts: 13
Member Since:
2011/12/28
sp_UserOfflineSmall Offline
184
2011/12/28 - 18:52
sp_Permalink sp_Print

kaymado said

 

hi pal,

 

to me it seems like you are trying to access the file from a location that does not exist (which can be caused by plugging in a usb flash drive for example).

 

One thing that is not yet resolved (for me at least), is the mounting. Whenever i plug in a hard drive or usb stick to the arnova, the programs moved to SD card, will not work. And my only fix so far is to restart the device. It all then works fine.

 

So... i guess that this is something related to it as the internal storage kind of disappears....

simply copy the arctools anywhere to built in memory and after ejecting the usb drive/stick (unplugg everything if you have to!), restart and then i believe you will be able to install arctools

 

remember than once you run the "root install google apps" they will only show once you restart the device.

Hi Thanks for the reply.  I have had no problem installing Arc Tools, it's where I click to download the market - this happens with all 4 options.  It does seem as if something is blocking the download location - I don't know where arc tools is trying to download to.

Thanks again.


Avatar
superman
New Member
Forum Posts: 6
Member Since:
2011/12/28
sp_UserOfflineSmall Offline
185
2011/12/28 - 19:09
sp_Permalink sp_Print

hey guys need alot of help can i install market with rooting the archos and if not were can i get thge RK ANDROIDTOOL at is it a download

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
186
2011/12/28 - 21:50
sp_Permalink sp_Print sp_EditHistory

Monjur said

This is brilliant staff! Thanks to Finless and Bob. The expanded internal memory for Apps installation is a great bonus, I can now install loads of apps.

However, there are some issues I would like to report.

One - After installation my 8gb Storage has turned into a 6.20 GB one! Is this expected?

Two - The Camera does not seem to work. I had to reboot a few times and only then the camera would work. Skype does not work with video, does not show video from the other end and also does not capture my video.

Three - Battery back up is a lot efficient than the original rom.

Anyway a big thanks for this good work and look forward to the next release!

 

Yes to give more memory to the system it had to come from some where.  My 4gig unit on stock rom showed 2.80gig free and 254mb for system.  With my ROM it now has 2.55gig and 459mb for system. this is after a fresh install no apps.  As you can see even with the stock ROM, 1.2gig is used for the ROM and OS install.  So your 8gig unit should be missing 1.2gig on a fresh stock rom install and will be missing 1.5 gig on my rom.  But again you got extra memory for system now so it is not gone.

 

Camera working or not has nothing to do with my ROM.  Skype did not work well on stock ROM and is the same on my ROM.  However there is a post in this forum about how to get skype simi-working so you can see others but they still cannot see you.  I think you turn the camera on before running skype or something like that. But then after quitting skype the camera wont work and you have to reboot.  Anyway, the issue is camera drivers that work with skype. Stock ROM or mine, same issue. Hopefully a new version a skype will come out that supports us.

 

Battery backup?  What is that? 

 

Bob

Avatar
vanschlong
New Member
Forum Posts: 9
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
187
2011/12/28 - 22:42
sp_Permalink sp_Print

Figured out what the iPlayer problem was, I'd installed flash player 11 and this was what was causing the problem, uninstalled and reloaded flash player 10.3 from appslib and all is working fine again now 🙂 Finally have my tab how I want it. Many thanks 

Avatar
nutbolt
New Member
Forum Posts: 4
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
188
2011/12/28 - 23:10
sp_Permalink sp_Print

finless said

nutbolt said

I'm guessing its just ok to open and modify boot.img on linux then? I need to remove the 1st splash screen and maybe make one of my own customs if the time comes to sell the device on I'd rather not have something screaming out that its been modded with

 

You can do that.  You better understand boot.img on RK29 devices.  It is not as easy as you think it is.
I am sorry you do not like my splash screen but everything I did to learn to modify boot.img and make your own can be found here.  Have at it!  It's pretty fun to learn 🙂
/blog/forum/arnova-10-g2/modifying-the-arnova-10-g2-custom-firmware/

I am going to tell you it is not easy!  Boot.img is so picky about how things are made and put together, a wrong change and it wont work! If you are on Windows... FORGET IT!  Touch date changes from windows to files you use in boot.img can make a boot.img not work! Follow my learning process and you can make a successful boot.img.

 

Bob

Cool, thanks. I managed to wipe it okay once I extracted the .imgs. I also put the android particles boot logo on, guess I got sick of the Arnova logo as well. It's not that I don't like your splash screen and kudos to you for doing it, it's just I like to customize my things. I wasn't too hard to do on linux with the Wendel tools and using the android sdk

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
189
2011/12/29 - 00:38
sp_Permalink sp_Print

Cool.... Glad you got it.  The tricky part was learning how to unpack boot.img.  You have to strip off the first 8 bytes before gzip will recognize it.  Then when you make a new boot.img you have to add the CRC with rkcrc.  Then edit the first 4 bytes from PARM to KRNL. I assume you got that part OK?  That part was killing me as if you do not edit PARM to KRNL the Arnova wont boot.  I would sometimes skip that step when I was learning and testing so I finally scripted all of it.

 

Bob

Avatar
nutbolt
New Member
Forum Posts: 4
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
190
2011/12/29 - 04:57
sp_Permalink sp_Print

finless said

Cool.... Glad you got it.  The tricky part was learning how to unpack boot.img.  You have to strip off the first 8 bytes before gzip will recognize it.  Then when you make a new boot.img you have to add the CRC with rkcrc.  Then edit the first 4 bytes from PARM to KRNL. I assume you got that part OK?  That part was killing me as if you do not edit PARM to KRNL the Arnova wont boot.  I would sometimes skip that step when I was learning and testing so I finally scripted all of it.

 

Bob

correct about modifying the first 8 bytes in hex (header file) and I remembered what you said in your previous post you linked to about setting it back to KNRL or else the device goes into kernel panic mode, but yeah it wasn't too hard to do. Thanks for the groundwork.

Avatar
drewfn
New Member
Forum Posts: 1
Member Since:
2011/12/29
sp_UserOfflineSmall Offline
191
2011/12/29 - 05:01
sp_Permalink sp_Print

Just bought a Arnova 10 G2 tablet.......Was looking at flashing with the ROM on here. The question I have I see all the posts refer to a RK 2918 cpu......Mine has ARM Cortex A8 1ghz cpu, will this ROM work? I don't want to brick it, but I need to get rid of this stock ROM....

 

Drew

Avatar
nwhite89
Active Member
Forum Posts: 21
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
192
2011/12/29 - 09:37
sp_Permalink sp_Print

superman said

hey guys need alot of help can i install market with rooting the archos and if not were can i get thge RK ANDROIDTOOL at is it a download

 

You've been given the steps and links to the downloads (RK Tool) quite a few times now its in the Zip file that Finless has created (Link below)

I posted it on this page further up …. to do the RKAndriod Tool download Finless ROM (below) unzip it and read the text file named "READ ME"

 

1) Run RKAndriodTool v1.29 (on Stock ROM)

a) Erase IDB again

2) Installed Finless Rooted ROM v1.1 

Link Here : /assets/firmware/Arnova10G2/arn10g2-23-1_1.zip

3) Gone through Startup Wizard

4) ERASE NAND and then Privacy Factory Reset

5) Setup Wi-Fi

6) Installed ArcTool v0.57

Link Here : /blog/wp-content/uploads/2010/12/com.arctablet.arctools057.apk

7) Used ArcTools to install "Default Apps & Market 3.4.4 (root Install)

8) Turned off & on

9) Loaded Market app and added account

10) Downloaded new APPS! 🙂 

Avatar
damo
Kingston upon hull, UK

Contributor
Forum Posts: 243
Member Since:
2011/10/16
sp_UserOfflineSmall Offline
193
2011/12/29 - 09:51
sp_Permalink sp_Print

drewfn said

Just bought a Arnova 10 G2 tablet.......Was looking at flashing with the ROM on here. The question I have I see all the posts refer to a RK 2918 cpu......Mine has ARM Cortex A8 1ghz cpu, will this ROM work? I don't want to brick it, but I need to get rid of this stock ROM....

 

Drew

Yes that is fine that is the name of the chipset for the arnova 10g2

Avatar
Le0
New Member
Forum Posts: 5
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
194
2011/12/29 - 11:46
sp_Permalink sp_Print

works gereat just one thing can't write to sd card don't know it this is something to do with the firmware.

Avatar
misc
New Member
Forum Posts: 5
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
195
2011/12/29 - 14:11
sp_Permalink sp_Print

finless said

For Market login problems, do these steps and it usually solves it.  I have had it happen a few times myself and it does matter which version of Market I installed.

1) Go into manage apps, select all apps (not just downloaded), and find; Google Services Framework.  Click on that and click on the clear data button.

2) No go back and find Gmail if you have it installed.  Go into that and clear data as well.

3) DON'T DO ANYTHING at this point!  Power off completely and power back on.

When you come back up go right to the market and try to logon using your existing account.  It should work.  This procedure has always cleared up the first login issues I have had when first installing the Market.

Thanks Bob. This worked after a couple of attempts. Tablet is 1,000 times more useful now! Laugh

This topic is locked
Forum Timezone: Europe/Paris

Most Users Ever Online: 803

Currently Online:
67 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (56), Phone (11)

Top Posters:

finless: 604

DarthJabba: 551

maikal: 394

mussonero1: 350

alex: 252

damo: 243

DanielVd: 237

Mark06: 222

Newest Members:

fouadbkf05

jima

Azabatxe1

Azabatxe

igijabet

jacksonrid

Forum Stats:

Groups: 10

Forums: 185

Topics: 6037

Posts: 60500

 

Member Stats:

Guest Posters: 43

Members: 262194

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix