Forum switched to read-only as of 2020/06/01


Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
[ ROM ] Arnova 10 G2 improved custom firmware update (full root, increased app storage space) by Finless
sp_BlogLinkWhite Read the original blog post
Tags: bob
Related Tags This topic is locked
Avatar
nutbolt
New Member
Forum Posts: 4
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
136
2011/12/27 - 19:23
sp_Permalink sp_Print

@finless

 

Well done on this Bob, however is there any way to remove disable the big green splash screen that appears on boot or do you have a replacement boot.img that we could all use, or could we add our own images to the boot logo?

 

Laugh

Avatar
nwhite89
Active Member
Forum Posts: 21
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
137
2011/12/27 - 19:52
sp_Permalink sp_Print

Using an app called "AppBrain App Market" it still download and installs via Google's Marketplace. I noticed that when finding an app that I cannot now find (for example "Facebook for Andriod") you can use AppBrain to take you to the page for this within Market however Google's Marketplace states "Your device isn't compatible with this item."

Avatar
olewisjr
New Member
Forum Posts: 2
Member Since:
2011/12/25
sp_UserOfflineSmall Offline
138
2011/12/27 - 21:09
sp_Permalink sp_Print
Big thanks!!!!!! goes out to Finless for the Arnova 10 G2 improved custom firmware update (full root, increased app storage space) for increasing my storage space on my Arnova 10 G2 from having 200mb to 445 mb of space left. Also for helping me restore (Flash) my tablet. I did a custom firmware released 11/2011 and I bricked. I folowed the instructions that was given by Finless and now I am back up and running (faster than before mind you). Finless you are the best. Now if I can get Appslib to work as good. 
Avatar
damo
Kingston upon hull, UK

Contributor
Forum Posts: 243
Member Since:
2011/10/16
sp_UserOfflineSmall Offline
139
2011/12/27 - 21:14
sp_Permalink sp_Print

I live in the UK but have the Android Market working fine.

 

I originaly installed the market from Arctools 0.60 but although it installed the market I didnt have any apps from within the market and each category only show 2 apps in each so this is what I did to get it working.

 

I opened Arctools and than went onto the sub-section of the program remove apps, and from there ticked everything in there to remove it. Closed that program and went into the settings/applications on the tablet and If I remember rightly removed the market by clicking the usual un-install.


I than went into storage settings and erased the nand flash. Installed v0.57 of Arctools and installed the rootless version of the market the one furthest to the bottom. Rebooted and clicked on the Market icon in the  apps drawer. Started it up and did the usual accepting terms, entering my Google account details and made sure that privacy setting where set to back up my data and automatic  restore.


After that it was working fine.


Avatar
p2pjack

Contributor
Forum Posts: 13
Member Since:
2011/12/12
sp_UserOfflineSmall Offline
140
2011/12/27 - 21:44
sp_Permalink sp_Print

Thank you finless for work on this rom . I had problems with market not connecting yesterday so flashed back to stock and this morning reflashed this rom again and no problems all working has it should installed market with arctool v0.57(root install) made sure i connected the wifi before i installed arctool has i did not do that yesterday and that was the only thing i did different . Oh yea i'm in the uk and have uk market installed thank you again for all your hard work on this 🙂

Avatar
tanktech87
Active Member
Forum Posts: 21
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
141
2011/12/27 - 21:51
sp_Permalink sp_Print

@ Damo

 

Do you mean he top one when you say the one furthest from the bottom or do you mean Default apps and market (rootless 3.4.4) the 3rd in the list?

Avatar
tanktech87
Active Member
Forum Posts: 21
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
142
2011/12/27 - 22:03
sp_Permalink sp_Print

@ Damo

 

Forget my last post dude. Did everything you said and it worked !! (for now)...sure i tried that myself last night though. oh well seems ok now. cheers dude

 

BIG thumbs up for Bob.......you da maaaaan !!!!!

 

But any chance i could have a personalized boot.img? let me know dude

 

PEACE OUT

Avatar
damo
Kingston upon hull, UK

Contributor
Forum Posts: 243
Member Since:
2011/10/16
sp_UserOfflineSmall Offline
143
2011/12/27 - 22:05
sp_Permalink sp_Print

sorry just meant the one that says root install.

Avatar
topilno
New Member
Forum Posts: 2
Member Since:
2011/12/25
sp_UserOfflineSmall Offline
144
2011/12/27 - 22:46
sp_Permalink sp_Print sp_EditHistory

After several failures i flashed with 1.1 and tried both 0.57 and 0.60 with no luck.

The rooted setup installed only the market, and it didn't work too, so i decided to reset and try the not rooted setup.

After the nth factory reset and a lot of profanities i found the right way (at least for me): Arctools 0.60 and 3.44 not rooted, now i have gmail, market, reinstalled all my apps (download from market didn't work before, so the market was useless) and everything looks fine.

Only souvenir from the past, an app in the market that i don't have anymore on both phone and tablet, but i can live with that.

Thanks for the great ROM!

Laugh

Avatar
Jonni
New Member
Forum Posts: 10
Member Since:
2011/12/08
sp_UserOfflineSmall Offline
145
2011/12/27 - 22:55
sp_Permalink sp_Print

finless said

For Market login problems, do these steps and it usually solves it.  I have had it happen a few times myself and it does matter which version of Market I installed.

1) Go into manage apps, select all apps (not just downloaded), and find; Google Services Framework.  Click on that and click on the clear data button.

2) No go back and find Gmail if you have it installed.  Go into that and clear data as well.

3) DON'T DO ANYTHING at this point!  Power off completely and power back on.

When you come back up go right to the market and try to logon using your existing account.  It should work.  This procedure has always cleared up the first login issues I have had when first installing the Market.

 

giga8547, if you read some of the posts lately about appslib, they have been having some problems the last few days. Same complaints from many for at least 3 days now.  This issues with it have nothing to do with the ROM. 
My wife played Angry birds all day yesterday on my 10G2 with no hangs or issues, so you might be right about the hardware if you're having trouble or maybe some other app is causing a problem?  I had a live wallpaper installed early on that would cause all kinds of instability on the stock rom.

 

Jonni, your screen looks just like the issue of not clicking the EraseIDB before flashing.  Erase IDB erases the Image Definition Block.  This HAS to be done since we are changing the size of the image block for the new firmware.  e.g. we are making more space for apps, etc.  If you do not erase the IMGs get installed wrong and you get a garbage screen like yours is showing.  So try again and eraseIDB and flash with my firmware.  If you want to go back to stock then use these instructions here for doing that.  You cannot use my tools to flash stock firmware since you do not have the stock firmware in IMGs.  You only have update.img.  So follow these instructions here:

/blog/featured/flashing-arnova-g2-rockchip-2918-rockchip-flashing-tool/

 

Bob

Unfortunately it results the same thing

After the initial screen where it shows Arnova G2 Fully rooted it goes to the stripe screen (with less stripes lol)

I Erase IDB twice and it gives the same result.

Are there any way to wipe of all the data to make a clean install?

I dont want to enter the New Year with a brick 😛

Avatar
tanktech87
Active Member
Forum Posts: 21
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
146
2011/12/28 - 01:40
sp_Permalink sp_Print

Does anyone know if the 10g2 supports usb controller? for emulators etc...Laughive been looking everywhere....

Avatar
miche.clb10g2
New Member
Forum Posts: 1
Member Since:
2011/12/28
sp_UserOfflineSmall Offline
147
2011/12/28 - 01:49
sp_Permalink sp_Print

Hi guys I m new here!
I'm writing for a major issue with the new custom fw! I ve installed it without problems and it works great with really improved startup speed but..installing the market with arctool (both 57/60 version) i can't login to it, neither i can create new account both for gmail too! When it tries to connect with google servers it tries for some minutes but then it says "cant estabilish reliable data connection to the servers"! But wifi works !
I ve also tried the suggested clear data from app manager but there is no way to solve it! I have to install the firmware again? How can i solve this issue??
Thank you!!

Avatar
tanktech87
Active Member
Forum Posts: 21
Member Since:
2011/12/26
sp_UserOfflineSmall Offline
148
2011/12/28 - 03:12
sp_Permalink sp_Print

best thing to do is re-flash the firmware, then use arctools 0.57 (turn on and connect to wifi before loading arctools) then use the bottom package 3.4.4 rooted. took some time but worked for me.

 

or u could erase nand flash in settings....damo as listed the instruction in a few posts above 🙂

Avatar
nutbolt
New Member
Forum Posts: 4
Member Since:
2011/12/27
sp_UserOfflineSmall Offline
149
2011/12/28 - 04:23
sp_Permalink sp_Print sp_EditHistory

I'm guessing its just ok to open and modify boot.img on linux then? I need to remove the 1st splash screen and maybe make one of my own customs if the time comes to sell the device on I'd rather not have something screaming out that its been modded with

Avatar
finless
Stanton, Ca

Contributor
Forum Posts: 604
Member Since:
2011/12/10
sp_UserOfflineSmall Offline

Thanks Received: 2
150
2011/12/28 - 05:23
sp_Permalink sp_Print

nutbolt said

I'm guessing its just ok to open and modify boot.img on linux then? I need to remove the 1st splash screen and maybe make one of my own customs if the time comes to sell the device on I'd rather not have something screaming out that its been modded with

 

You can do that.  You better understand boot.img on RK29 devices.  It is not as easy as you think it is.
I am sorry you do not like my splash screen but everything I did to learn to modify boot.img and make your own can be found here.  Have at it!  It's pretty fun to learn 🙂
/blog/forum/arnova-10-g2/modifying-the-arnova-10-g2-custom-firmware/

I am going to tell you it is not easy!  Boot.img is so picky about how things are made and put together, a wrong change and it wont work! If you are on Windows... FORGET IT!  Touch date changes from windows to files you use in boot.img can make a boot.img not work! Follow my learning process and you can make a successful boot.img.

 

Bob

This topic is locked
Forum Timezone: Europe/Paris

Most Users Ever Online: 803

Currently Online:
46 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (45), Phone (1)

Top Posters:

finless: 604

DarthJabba: 551

maikal: 394

mussonero1: 350

alex: 252

damo: 243

DanielVd: 237

Mark06: 222

Newest Members:

igijabet

jacksonrid

usdown

ibob64

kawi

vetBro

Forum Stats:

Groups: 10

Forums: 185

Topics: 6037

Posts: 60500

 

Member Stats:

Guest Posters: 43

Members: 262194

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix