Latest product reviews
ARCHOS 50 Diamond
ARCHOS GamePad2
ARCHOS
Smartphones
ARCHOS
TV Connect
ARCHOS 101 XS

A A A
Avatar

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?

ClockworkMod (CWM) Recovery easy install for RK3066 and RK3188 -- TWRP/CWM Flash-Tool and root for RK3288

 Please donate to support OMA and CrewRKTablets firmware work, thank you !

sp_Feed sp_TopicIcon
Enabling Wi-FI Adhoc mode with wpa_supplicant file for tethering and other uses
Avatar
vadim537
–†–ĺ—Ā—Ā–ł—Ź

Contributor
Forum Posts: 9
Member Since:
2012/06/11
sp_UserOfflineSmall Offline
1
2012/06/22 - 11:59
sp_Permalink sp_Print

All smartphones and some mobile phones can be switched in a wi-fi-router mode (if these devices support wifi). Usually anybody has no problems on this matter. On many devices it is a standard mode. Devices with the Windows operating system easily find such wifi point of access and are capable to be connected to them. Now it would seem there is nothing more simply than to connect Arnova 9 G2 to such point. However, it isn't so simple, as it seemed....

Well-known that officially android doesn't support wifi ad-hoc connection. Android devices don't find such wifi point of access or can't be connected to such points.

How to solve this problem? Process of the decision is described here (site in Russian).

http://acer-a500.ru/faq/466-faq-po-razdache-wifi-pri-pomoschi-ad-hoc-soedineniya.html

The essence of the solution of this problem is reduced to replacement of wpa_supplicant file. As the old file is renamed previously, always there is a possibility to return it to the place of the new file.

I decided to try to make it on the Arnova 9 G2.

At first I renamed in the Rootexplorer program the original sistem/bin/wpa_supplicant file (on a case of state of emergency). The new name of the file became wpa_supplicant_old. I inserted to this folder this wpa_supplicant file (after unpacking):

http://acer-a500.ru//uploads/files/1313343315_wpa_supplicant_xoom_wifi_adhoc.zip

In the Root Explorer program long pressing on the new file. It is necessary to choose "Permissions" and to put ticks in the right places.

 

FAQ –Ņ–ĺ —Ä–į–∑–ī–į—á–Ķ WiFi –Ņ—Ä–ł –Ņ–ĺ–ľ–ĺ—Č–ł AD-HOC —Ā–ĺ–Ķ–ī–ł–Ĺ–Ķ–Ĺ–ł—Ź –ī–Ľ—Ź Acer Iconia TAB A500Image Enlarger

It is necessary to reboot a tablet. After that the tablet found phone as a point of access of wifi. I easily could connect it using the password of a point of access.

Now the Internet is available on a tablet. After a week of work of the new file (wpa...) I didn't notice failures in tablet work.

Avatar
admin

admin
Forum Posts: 5871
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
2
2012/06/22 - 12:12
sp_Permalink sp_Print

Thanks Vadim, brilliant ! It completes well the explanations given by globula_neagra in another thread.
For convenience, I've attached the wpa_supplicant_xoom_wifi_adhoc.zip file to this post and I've reduce this post title and moved the post to a more general category as well, I hope you don't mind. 

I should be able include that feature in Arctools soon, so it's easier to install. I'll update here when it's ready.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
globula_neagra
Birmingham

Moderator

Firmware Guru
Forum Posts: 2424
Member Since:
2012/01/05
sp_UserOfflineSmall Offline

Thanks Received: 264
3
2012/06/22 - 12:17
sp_Permalink sp_Print

this is good, i was saying also, it is about trial and error test till you get a good supplicant ūüėÄ

Avatar
Gizzajob
New Member
Forum Posts: 2
Member Since:
2012/07/23
sp_UserOfflineSmall Offline
4
2012/07/24 - 14:47
sp_Permalink sp_Print

Hi,

I've been trying to add the above to my Arnova 10b g3. I've flashed kasty-arn10bg3-40-041a.zip and all is fine (Google Play app works). I've downloaded wpa_supplicant_xoom_wifi_adhoc-1.zip and using File Expert have managed to change the name of the original wpa_supplicant file. My problem is when trying to copy and paste the downloaded file to system/bin. File Expert copies the file (in the downloaded folder) but doesn't paste it . I know the copy works as I've copied the zip file to system/bin but when I try to decompress the file it doesn't work either.

Has anyone any idea why the paste or decompress doesn't work?

 

Thanks


Avatar
admin

admin
Forum Posts: 5871
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
5
2012/07/24 - 14:59
sp_Permalink sp_Print

Are you able to rename the original file in system/bin ?

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
vadim537
–†–ĺ—Ā—Ā–ł—Ź

Contributor
Forum Posts: 9
Member Since:
2012/06/11
sp_UserOfflineSmall Offline
6
2012/07/24 - 15:06
sp_Permalink sp_Print

I think that you need to use program Rootexplorer and attentively to follow the instruction. Do as all is written also it will turn out easily.

Avatar
Gizzajob
New Member
Forum Posts: 2
Member Since:
2012/07/23
sp_UserOfflineSmall Offline
7
2012/07/24 - 15:39
sp_Permalink sp_Print

Thanks admin and vadim537 for your replies.

 

admin,

Yes I am able to rename the original file in system/bin. I used wpa_supplicant_old for the name. I made the system read/write.

 

vadim537,

Is Rootexplorer another app to download? I only ask because File Expert has an option to turn Root Explorer on which I have done.

 

Thanks 

Avatar
admin

admin
Forum Posts: 5871
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
8
2012/07/24 - 16:24
sp_Permalink sp_Print

Gizzajob,

I think vadim is referring to the Root Explorer application.

I'm currently implementing in ArcTools the procedure described by vadim in post #1, there should be a test version ready by the end of the day... if you want to give it a try.

Also, try to update to latest firmware (0.42) as it's based on a more recent Arnova firmware.

Cheers.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
admin

admin
Forum Posts: 5871
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
9
2012/07/24 - 17:16
sp_Permalink sp_Print

My package with wpa_supplicant in ArcTools is ready.

If anyone is interested in testing, please let me know (having a working ADB connection to the tablet may help, in case things go wrong).

Cheers.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
vadim537
–†–ĺ—Ā—Ā–ł—Ź

Contributor
Forum Posts: 9
Member Since:
2012/06/11
sp_UserOfflineSmall Offline
10
2012/07/24 - 18:28
sp_Permalink sp_Print

Yes, admin, exactly so, I meant Root Explorer application.

One rather important note concerning pad operation after wpasupplicant file changeover. __________________________________________________________________________ In case of switching on of wifi there are no problems with connection while a tablet in the active mode. If after that the tablet long is in a sleeping mode in case of tablet again switching on in the active mode very often wifi hangs up. The single solution of this problem - to reboot a tablet and again to switch on wifi. As I don't know different ways to get on a tablet access to the mobile Internet, I need to use this not debugged method. I don't think that it is a big problem (in any case for me).Wink

Avatar
maskins
North Carolina
New Member
Forum Posts: 5
Member Since:
2012/08/06
sp_UserOfflineSmall Offline
11
2012/08/16 - 15:02
sp_Permalink sp_Print

I would be willing to test.  I have tried the steps above but after I do my wireless will not turn back on.

admin said
My package with wpa_supplicant in ArcTools is ready.

If anyone is interested in testing, please let me know (having a working ADB connection to the tablet may help, in case things go wrong).

Cheers.

Avatar
admin

admin
Forum Posts: 5871
Member Since:
2010/09/11
sp_UserOfflineSmall Offline

Thanks Received: 3163
12
2012/08/16 - 15:51
sp_Permalink sp_Print

maskins, using my package and procedure probably won't work any better, as it uses the same file linked by vadim537 and automates the wpa_supplicant file installation procedure... 

The best you have to do for the moment is restore the original file; if you haven't made a backup, just ask and somebody may be help to help...

Cheers.

If you like our web site, applications and firmwares, feel free to support our site. Donations are used to pay the bills for our server hosting costs, development tools and purchase new tablets to support.

Avatar
maskins
North Carolina
New Member
Forum Posts: 5
Member Since:
2012/08/06
sp_UserOfflineSmall Offline
13
2012/08/16 - 16:02
sp_Permalink sp_Print

ok I have restored the original file and it is working now.  I would just really like to be able tether to my phone.

Avatar
Mr.Lewis
New Member
Forum Posts: 1
Member Since:
2012/08/17
sp_UserOfflineSmall Offline
14
2012/08/17 - 20:10
sp_Permalink sp_Print

admin said
maskins, using my package and procedure probably won't work any better, as it uses the same file linked by vadim537 and automates the wpa_supplicant file installation procedure... 

The best you have to do for the moment is restore the original file; if you haven't made a backup, just ask and somebody may be help to help...

Cheers.

I Think he has not unzipped the downloaded file before replacing the original file.

Avatar
maskins
North Carolina
New Member
Forum Posts: 5
Member Since:
2012/08/06
sp_UserOfflineSmall Offline
15
2012/08/17 - 20:14
sp_Permalink sp_Print

Mr.Lewis said

admin said
maskins, using my package and procedure probably won't work any better, as it uses the same file linked by vadim537 and automates the wpa_supplicant file installation procedure... 

The best you have to do for the moment is restore the original file; if you haven't made a backup, just ask and somebody may be help to help...

Cheers.

I Think he has not unzipped the downloaded file before replacing the original file.

Yes I did. I extracted it, renamed the original file, then copied the new one. and then set the permissions.

Forum Timezone: Europe/Paris

Most Users Ever Online: 749

Currently Online: paparazzo_1, astanaitis, iqbalje
210 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Devices in use: Desktop (178), Phone (33), Tablet (2)

Top Posters:

Oma7144: 5664

globula_neagra: 2424

finless: 604

DarthJabba: 551

exelletor: 450

JochenKauz: 450

cracktech: 430

maikal: 394

Newest Members:

iqbalje

astanaitis

ascaval2

abcgame01

lovelovelove

at1491

Forum Stats:

Groups: 10

Forums: 185

Topics: 5884

Posts: 58439

 

Member Stats:

Guest Posters: 43

Members: 255376

Moderators: 5

Admins: 1

Administrators: admin

Moderators: globula_neagra, exelletor, JochenKauz, Oma7144, cracktech


CrewRKTablets moderators: JochenKauz and Astralix