The great guys from xda-developers.com have managed to enable Special Developer Edition (SDE) on the ARCHOS 101 XS, opening the tablet to custom firmware, root access and other goodies. XDA’s procedure requires a few downloads and manipulations, globula_neagra has made the job easier with just a batch file and instructions to get your ARCHOS 101 XS rooted in a few minutes and just a few clicks.

ARCHOS101_XS_root_DSC_0286_b

This procedure requires that your Archos 101 XS to run on Android 4.0 ICS firmware, it will not work with latest Android 4.1 Jelly Bean. If you are running an Android 4.1 Jelly Bean firmware, you will need to downgrade: Get firmware_archos_it4x.aos (firmware 4.0.26 for ARCHOS 101 XS)

Download Easy root package for the ARCHOS 101 XS

ARCHOS_101XS_root_v01.zip

This package is specific to the ARCHOS 101 XS tablet and should not be installed on other devices.

WE WILL NOT BE HELD RESPONSIBLE FOR ANY DAMAGE TO YOUR DEVICE.

THIS FIRMWARE UPDATE IS USED AT YOUR OWN RISK.

Execute run_me.bat batch file and follow the instructions on your screen console.

Please note that enabling SDE and flashing a non officicial firmware may void your warranty.

Feel free to use our ARCHOS 101 XS forum if you have any comments or questions.

Thanks to scholbert, letama, surdu_petru, Paul O’Brien and cajl for their work on rooting the 101 XS

11 COMMENTS

  1. bonjour,
    j’ai une énorme probleme j’ai mis votre root qui marchais au début en mode de lancement par défault et depuis ma tablette n’a pus de recovery mode n’y de developer mode
    -désolé pour la réponse en francais mais c’est pressé
    a+

  2. Hi there! I am Marcelo, Thank for the video but I was looking on Google all day long how downgrade my archos 101 xs actually on 4.1.2.. for be able to root it, please can you explain or give us a link for downgrade to 4.0?

      • hello again and thanks , the link i saw it and download the firmware but i didnt know how to downgrade but it diesent matter beacause i found the information, but now i installed succefully the firmware 4.0.26 from the link above, i put my tablet on usb debugging mode, I connect my tablet by usb, i click on run_me file , i read the instruction and when i click anykey the message is: device not found !!! why?

Leave a Reply