Archos 7 HT v1 (version 1) and Archos 7 HT v2 (version 2)

31

This short post helps to differenciate Archos 7 Home Tablet v1 (7HTv1) and Archos 7 Home Tablet v2 (7HTv2) specifications

Archos 7 HT version 2 bring some small improvments to Archos 7 HT version 1. Among other things Version 2 offers a new Rockchip RK2818 CPU, compared to a Rockchip RK2808 CPU on version 1. Both machines runs at 600 Mhz, the new architecture on V2 let the system run Android 2.1 Eclair instead of Android 1.5 Cupcake on V1.

If you own an Archos 7 HT and want to check with version you have, please go to Settings Menu / About Device, the Model number should read:

A70HB if you have an Archos 7 Home Tablet v1
Build number should NOT say ECLAIR

A70BHT if you have an Archos 7 Home Tablet v2
Build number should say ECLAIR

If you are looking for an updated Eclair/Froyo firmware with Market and Root for your device, please check our Archos 7HTv1 or Archos 7HTv2 page depending your model.

31 COMMENTS

  1. Hallo,

    Ich habe das archos 7c Home Tablet
    Model: A70CHT
    Firmware: 1.0.3
    Kernel: 2.6.25
    Build number: V0.18.ECLAIR.eng.root.20110506.205202

    aber sobald ich ein Update nutzen möchte kommt die meldung das die ein “invalid file” ist mit der aufforderung dieses zu löschen.

    Was kann ich tun?

  2. I have a version identification problem — My Archos 7 Home Tablet has “A70HB” on the back (with the “A7” being in a bigger font than the “0HB”, but when I go into the Settings menu, I see Model Number A70BHT, Firmware version 1.0.0, Kernel version 2.6.25, Build number V0.18.ECLAIR.eng.root.20101202.141355 .

    I seem to remember I had some sort of automatic update a few months ago through AppsLib — but the latest stock firmware image seems to date from January 2011. So I am trying to find out — Do I in fact have a 7HTv2, or is this just a side effect of some update to a 7HTv1?

    I’d like to try an update (stock or non-stock) — but I’d like to be absolutely sure of my version so I don’t brick my device. Is it possible that Archos released some v2 tablets using old (pre-painted) v1 cases? …. Thanks for any help!

    • @gregn

      I have exactly the same identification problem. On the back A70BH and in Settings A70BHT.

      I have the feeling that Archos took the v1 devices and gave it some sort of firmware update.

      Now, as we face the same issue I was wondering if you ever managed to get a full Android Market working on your device? For me v1 firmware updates don’t work and v2 firmware updates show countless bugs.

      Many thanks.

  3. I bought two Archos 7 internet Tablets from woot.com out of the box 1 was a version 1 the other version 2. From the info on this site I took yar28 and updated the firmware using what admin said to use as well as the step by step that was given after decompressing the files it took less than 30 minutes. I used yar28.zip and the android 2.1 firmware. the tablet is working great. the only other question is there a 2.2 firmware available for the version 1 tablet.

  4. I have a archos 7 home tablet (cup cake) .
    it recently started giving me a “The process.android.process.arcore has stopped uexpectedly.”
    and the only option is to force close is there a way to fix it i have tried the reset and it does not help. please if you have ever incountered this let me know? Thank you

      • hey, thanks for the quick response, yes i have the exact same firmware and info in my settings/about

        also, this is the second time, but just randomly all my apps are force closing, the first time i was able to go to settings/privacy/factory reset, this time however its the acore process so i can’t even get to my settings, any advice how to boot into archos recovery and data wipe? i cant find anything on the archos site, forums, youtube, or user manual. i’ve only had this thing since 7pm last night, the only suspicious application that MAY be causing this i have installed was advanced task killer pro or maybe applanet market. any help is appreciated.

        • hi i am having exactly the same problem. i tried the update firmware as archos help site told me to but still no joy, took it back to staoles who tried but still no luck. they said to highlight everything from the tablet on my comp and move it all off. then try to put back on 1 by 1?? not sure if this is right as not tried it yet. have you had any luck yet with yours? would appreciate any advice on how to fix this. thanks